Closed Bug 1158727 Opened 5 years ago Closed 5 years ago

[Dialer]In enmergency dial pad, if user taps delete/numeric button, the cursor will always return to the end of the entered digits.

Categories

(Firefox OS Graveyard :: Gaia::Dialer, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

VERIFIED FIXED
2.2 S11 (1may)
blocking-b2g 2.2+
Tracking Status
b2g-v2.2 --- verified
b2g-master --- verified

People

(Reporter: xiongfuchao, Assigned: drs)

References

Details

(Whiteboard: [v2.2-nexus-5-l])

Attachments

(5 files)

Attached video video_1559.mp4
[1.Description]:
[Flame v2.2 & v3.0][Nexus5 v2.2 & v3.0][Dialer]When user try to delete/add a number via tapping the middle of a string you've inputted, the cursor will always return to the end of the string, then device executes operation.
Found time:15:59
See attachment:logcat_1559.txt & video_1559.mp4

[2.Testing Steps]: 
Prerequisite:Set a passcode lock.
1.Open emergency dial plate via lockscreen.
2.Input a any digits(123456789).
3.Move the cursor by tapping 5.
4.Tap delete icon.
5.Clear digits panel.
6.Repeat 1~3.
7.Tap 5.

[3.Expected Result]: 
4.Cursor should go between 4 and 5, and when you tap delete button, 4 should be deleted. 
7.Cursor should go between 4 and 5, and when you tap 5, 5 will be inserted between 4 and 5.

[4.Actual Result]: 
4.The cursor will return to the end and 9 is deleted. 
7.The cursor will return to the end and 5 is added to end of digits.

[5.Reproduction build]: 
Flame 2.2(affected):
Build ID               20150426002504
Gaia Revision          265ca0bc9408c21fc4b25a259fcee7fb642cd06b
Gaia Date              2015-04-24 19:13:28
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/1908685d798d
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150426.043030
Firmware Date          Sun Apr 26 04:30:42 EDT 2015
Bootloader             L1TC000118D0

Flame 3.0(affected):
Build ID               20150426160201
Gaia Revision          b4c949cdc780893897c9b45c1adea46e2eb694ff
Gaia Date              2015-04-24 16:13:40
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/37d60e3b8be6
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150426.193323
Firmware Date          Sun Apr 26 19:33:34 EDT 2015
Bootloader             L1TC000118D0

Nexus5 2.2(affected):
Build ID               20150426002504
Gaia Revision          265ca0bc9408c21fc4b25a259fcee7fb642cd06b
Gaia Date              2015-04-24 19:13:28
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/1908685d798d
Gecko Version          37.0
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150426.042708
Firmware Date          Sun Apr 26 04:27:25 EDT 2015
Bootloader             HHZ12f

Nexus5 3.0(affected):
Build ID               20150426160201
Gaia Revision          b4c949cdc780893897c9b45c1adea46e2eb694ff
Gaia Date              2015-04-24 16:13:40
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/37d60e3b8be6
Gecko Version          40.0a1
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150426.193304
Firmware Date          Sun Apr 26 19:33:21 EDT 2015
Bootloader             HHZ12f
[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test
Attached file lotcat_1559.txt
See Also: → 1121586
FWD to Copy/Paste
Flags: needinfo?(gchang)
This should have been fixed in 2.2 since bug 1121586. Regression window wanted.
Blocks: 1121586
blocking-b2g: --- → 2.2?
triage: 
blocking because this is major issue for new feature "text selection".
We blocked the similar one bug 1121586.
blocking-b2g: 2.2? → 2.2+
QA Contact: ychung
This issue is separate from bug 1121586, as the issue on the emergency dialer has never been fixed. I've checked a few build right after bug 1121586 was fixed, and a few older and more recent builds, and the issue always has existed:

BuildID: 20150119071100 > Repro
BuildID: 20150207085528 > Repro
BuildID: 20150209133034 > Repro 
BuildID: 20150224154149 > Repro
BuildID: 20150323164830 > Repro
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Contact: ychung
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
NI developers for more investigation.
Flags: needinfo?(hochang)
Flags: needinfo?(gduan)
Flags: needinfo?(gchang)
I believe this bug might belong to emergency-call app. I would suggest them to do the same thing as what dialer has done.
Flags: needinfo?(gduan)
Hi Dylan, Salvador, maybe you can help with this? Thank you.
Flags: needinfo?(salva)
Flags: needinfo?(hochang)
Flags: needinfo?(doliver)
Assignee: nobody → drs
Clearing the ni as Dough has just assigned the bug
Flags: needinfo?(salva)
Flags: needinfo?(doliver)
This is an amalgamation of the patches in bug 1126538 and bug 1121586, effectively re-applied to the Emergency Call keypad.
Attachment #8599529 - Flags: review?(thills)
Comment on attachment 8599529 [details] [diff] [review]
Fix Emergency Call keypad deletion when text cursor is placed.

Hi Doug,

It looks good to me.

Thanks,

-tamara
Attachment #8599529 - Flags: review?(thills) → review+
Comment on attachment 8599528 [details] [review]
[gaia] DouglasSherk:1158727-emergency-keypad-delete > mozilla-b2g:master

Thanks, Tamara.
Attachment #8599528 - Flags: review+
Keywords: checkin-needed
http://docs.taskcluster.net/tools/task-graph-inspector/#M0nwCYCtQ5OOU0RTiZzuzw

The pull request failed to pass integration tests. It could not be landed, please try again.
https://github.com/mozilla-b2g/gaia/commit/10beda255c84dbf733705286c7881d8781d4d34f
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Comment on attachment 8599529 [details] [diff] [review]
Fix Emergency Call keypad deletion when text cursor is placed.

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Incomplete functionality from bug 1121586.
[User impact] if declined: Emergency Call keypad + symbol and delete button long presses won't work as expected, instead jumping to the end of the currently entered string of digits.
[Testing completed]: Tamara and I tested this.
[Risk to taking this patch] (and alternatives if risky): Low.
[String changes made]: None.
Attachment #8599529 - Flags: approval-gaia-v2.2?(bbajaj)
Attachment #8599529 - Flags: approval-gaia-v2.2?(bbajaj) → approval-gaia-v2.2+
Attached video verify.mp4
This issue is verified fixed on latest build of Flame 2.2 3.0,Nexus5 2.2 3.0,the STR is same as Comment 0.
Reproduce rate:0/5
See verify.MP4

Flame 2.2(Fixed):
Build ID               20150503002500
Gaia Revision          8d14361337e608c8cdf165ea5034db5eda23b618
Gaia Date              2015-05-01 18:23:46
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/cb7cb6597c91
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150503.040203
Firmware Date          Sun May  3 04:02:15 EDT 2015
Bootloader             L1TC000118D0

Flame 3.0(Fixed):
Build ID               20150503160200
Gaia Revision          e18cce173840d6ff07fb6f1f0e0ffb58b99aab3e
Gaia Date              2015-05-02 04:27:01
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/dc5f85980a82
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150503.193941
Firmware Date          Sun May  3 19:39:52 EDT 2015
Bootloader             L1TC000118D0

N5_2.2(Fixed)
Build ID               20150503002500
Gaia Revision          8d14361337e608c8cdf165ea5034db5eda23b618
Gaia Date              2015-05-01 18:23:46
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/cb7cb6597c91
Gecko Version          37.0
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150503.040229
Firmware Date          Sun May  3 04:02:46 EDT 2015
Bootloader             HHZ12f

Nexus_5 3.0(Fixed):
Build ID               20150503160200
Gaia Revision          e18cce173840d6ff07fb6f1f0e0ffb58b99aab3e
Gaia Date              2015-05-02 04:27:01
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/dc5f85980a82
Gecko Version          40.0a1
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150503.193953
Firmware Date          Sun May  3 19:40:11 EDT 2015
Bootloader             HHZ12f
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][MGSEI-Triage+]
You need to log in before you can comment on or make changes to this bug.