Closed Bug 1158800 Opened 5 years ago Closed 5 years ago

Context in conversation errors are not displayed correctly on the standalone UI

Categories

(Hello (Loop) :: Client, defect, P1)

defect
Points:
1

Tracking

(firefox40 fixed)

RESOLVED FIXED
mozilla40
Iteration:
40.3 - 11 May
Tracking Status
firefox40 --- fixed

People

(Reporter: standard8, Assigned: standard8)

References

Details

(Keywords: regression, Whiteboard: [context])

Attachments

(2 files, 1 obsolete file)

Attached image Bad display
When I implemented bug 1142588, I changed the structure of the StandaloneRoomContextView and how the css worked. At the same time, I failed to update the parts for the failure messages, so they now display badly (see attached).
This fixes the issue, the errors are now displayed in the right place & are white.

You can test by setting loop.contextInConverations.enabled to true, restarting, and then generating a new conversation. The conversation url should have a # section, which can be altered or removed to show the error message.
Attachment #8597980 - Flags: review?(dmose)
Blocks: 1115340
Rank: 5
Whiteboard: [context]
Comment on attachment 8597980 [details] [diff] [review]
Context in conversation errors are not displayed correctly on the standalone UI.

Following discussion earlier, I'm updating this patch
Attachment #8597980 - Flags: review?(dmose)
Updated as per the meeting earlier today - the room failure messages are no longer displayed on the UI.

However, since we've got them translated etc, I'm dumping them to the console for now. If we do get into situations where we're not sure why it isn't working, then we should have a way of telling. If later we decide we really do want the messages back, then they aren't far away and we can either restore them or adjust as necessary.
Attachment #8597980 - Attachment is obsolete: true
Attachment #8598103 - Flags: review?(dmose)
Comment on attachment 8598103 [details] [diff] [review]
Don't show errors for context in conversations on the standalone UI as they may force the user into an unnecessary re-obtaining of the URL.

Review of attachment 8598103 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good to me; r=dmose
Attachment #8598103 - Flags: review?(dmose) → review+
Note: I landed it with a minor change to tests - I realised they were expecting the errors to be displayed, so I swapped them to checking that console.error was being logged.
Target Milestone: --- → mozilla40
https://hg.mozilla.org/mozilla-central/rev/efe637e79d07
Status: NEW → RESOLVED
Closed: 5 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.