Accessing contextual menu disables Unicode keyboard layouts

VERIFIED WORKSFORME

Status

()

VERIFIED WORKSFORME
17 years ago
16 years ago

People

(Reporter: bugmail, Assigned: nhottanscp)

Tracking

({intl})

Trunk
PowerPC
Mac OS X
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC; en-US; rv:0.9.6+) Gecko/20011218
BuildID:    201121808

The selection of a Unicode keyboard layout does not persist, and readily reverts
to the System default layout

Reproducible: Always
Steps to Reproduce:
1. Launch Mozilla
2. Spawn two Navigator windows
3. Use the Mac OS Keyboard Menu Bar menu to select the Extended Roman (U)
Unicode layout
4. Switch to the other Navigator window
5. Switch back to the original window

Actual Results:  The Keyboard Layout reverted to U.S.

Expected Results:  The keyboard layout should have remained Extended Roman (U).

This also happens sometimes within a single window, though I can't determine the
logic behind it. Sometimes just browsing around will cause the keyboard layout
to revert, and sometimes moving focus from the URL bar to the content area or
back will also cause a revert.

This happens on Mac OS X also, with less frequency. Usually keyboard layout is
preserved across window focus changes, but the U.S. layout icon can be seen to
briefly flash on the Mac OS Menu Bar before changing to the desired Extended
Roman (U).

Finally, it is not cear how to configure Mozilla to start up with a Unicode
keyboard layout selected every time.
(Reporter)

Comment 1

17 years ago
Adding dependency, and guessing fTang should be cc'd.
Depends on: 23363

Comment 2

17 years ago
nhotta, can you help to look at this one ?
Assignee: yokoyama → nhotta
(Assignee)

Updated

17 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla0.9.9
(Reporter)

Updated

17 years ago
Blocks: 101606
(Assignee)

Updated

17 years ago
Target Milestone: mozilla0.9.9 → mozilla1.2
(Reporter)

Comment 3

16 years ago
Note also that, on occasion, neither Unicode keyboard layout is selectable in
the Keyboard menu. Can't determine why.
(Reporter)

Updated

16 years ago
Keywords: intl
(Reporter)

Comment 4

16 years ago
Created attachment 88802 [details]
Screenshot showing Unicode keyboard layouts disabled in FizzillaCFM/2002061014
(Reporter)

Comment 5

16 years ago
Note also that accessing, then dismissing Fizzilla's contextual menu seems to be
a reliable way of disabling the Unicode keyboard layouts. They can be re-enabled
by putting Mozilla in the background, then returning it to the foreground.
(Reporter)

Comment 6

16 years ago
On further consideration, the issue originally reported may well be the correct
one. Choosing a keyboard layout for one window may not necessarily mean that it
should be set for another.

So, let's revise the summary to cover the issue reported in comment 5.
Summary: Unicode Keyboard Layout selection is not preserved → Accessing contextual menu disables Unicode keyboard layouts
(Reporter)

Comment 7

16 years ago
The issue of setting default keyboard layout is now bug 162878.
(Assignee)

Updated

16 years ago
Target Milestone: mozilla1.2alpha → ---
(Reporter)

Comment 8

16 years ago
*** Bug 168383 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 9

16 years ago
WorksForMe using FizzillaMach/2003020603.
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
OS: Mac System 9.x → MacOS X
Resolution: --- → WORKSFORME

Comment 10

16 years ago
Verified as WFM.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.