Closed Bug 1158960 Opened 5 years ago Closed 5 years ago

Reader view is broken in e10s mode

Categories

(Firefox :: Pocket, defect)

defect
Not set
Points:
3

Tracking

()

VERIFIED FIXED
Firefox 40
Iteration:
40.2 - 27 Apr
Tracking Status
firefox38.0.5 --- fixed
firefox39 --- fixed
firefox40 --- verified

People

(Reporter: ntim, Assigned: jaws)

References

Details

(Keywords: regression)

Attachments

(1 file, 1 obsolete file)

ReferenceError: CustomizableUI is not defined AboutReader.jsm:83:6
Screenshot : http://cl.ly/image/1N1f3l0J2l31
Keywords: regression
Flags: qe-verify?
Flags: firefox-backlog+
Assignee: nobody → jaws
Status: NEW → ASSIGNED
Iteration: --- → 40.2 - 27 Apr
Points: --- → 3
Flags: qe-verify? → qe-verify+
Attached patch Patch (obsolete) — Splinter Review
Attachment #8598256 - Flags: review?(gijskruitbosch+bugs)
Comment on attachment 8598256 [details] [diff] [review]
Patch

Review of attachment 8598256 [details] [diff] [review]:
-----------------------------------------------------------------

Can you rebase on top of my android fix that already landed, and make sure you check for "are we on fx desktop" in AboutReader.jsm and just force-hide the button if we're not?
Attachment #8598256 - Flags: review?(gijskruitbosch+bugs) → feedback+
Attached patch Patch (rebased)Splinter Review
Attachment #8598256 - Attachment is obsolete: true
Attachment #8598293 - Flags: review?(gijskruitbosch+bugs)
Comment on attachment 8598293 [details] [diff] [review]
Patch (rebased)

Review of attachment 8598293 [details] [diff] [review]:
-----------------------------------------------------------------

r=me. Wish we had tests for this.
Attachment #8598293 - Flags: review?(gijskruitbosch+bugs) → review+
https://hg.mozilla.org/mozilla-central/rev/f99efc229209
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 40
QA Contact: andrei.vaida
Verified fixed on Nightly 40.0a1 (2015-04-29), using Ubuntu 14.04 (x64), Mac OS X 10.9.5 and Windows 7 (x64).
Status: RESOLVED → VERIFIED
Comment on attachment 8598293 [details] [diff] [review]
Patch (rebased)

[Triage Comment]

Required for 38.0.5 Pocket launch.
Attachment #8598293 - Flags: approval-mozilla-release+
Attachment #8598293 - Flags: approval-mozilla-aurora+
Removing qe-verify+ keyword since the fix was already verified on Nightly 40.0a1 and e10s is not available for 39 and 38.0.5.
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.