WebRTC SDP does not support Ice restart

RESOLVED DUPLICATE of bug 906986

Status

()

RESOLVED DUPLICATE of bug 906986
4 years ago
4 years ago

People

(Reporter: kgoktas, Unassigned)

Tracking

38 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/42.0.2311.90 Safari/537.36

Steps to reproduce:

1- Create an audio/audio session between A and B.
2- A creates a new peer object and createOffer generates new ufrag parameter and sends it to B.
3- B sets new sdp with setRemoteDescription.


Actual results:

1- Audio/Audio session is established.
2- A creates a new offer with new ufrag and sends it to B.
3- B throws "InvalidSessionDescriptionError: ICE restart is unsupported at this time" while setRemoteDescription.


Expected results:

1- Audio/Audio session is established.
2- A creates a new offer with new ufrag and sends it to B.
3- B can set new ufrag with setRemoteDescription and after createAnswer+setLocalDescription, ice collection should be restarted.
(Reporter)

Updated

4 years ago
Severity: normal → blocker
Priority: -- → P2

Updated

4 years ago
Severity: blocker → normal
Component: Untriaged → WebRTC: Signaling
Priority: P2 → --
Product: Firefox → Core

Updated

4 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 906986
You need to log in before you can comment on or make changes to this bug.