Closed Bug 1159239 Opened 5 years ago Closed 4 years ago

720p Splash Screen Icons are not perfect circles

Categories

(Firefox OS Graveyard :: Gaia::System::Window Mgmt, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: padamczyk, Unassigned)

References

Details

(Keywords: polish, Whiteboard: [systemsfe])

Attachments

(2 files)

Attached image 2015-04-27-17-06-47.png
There's some weird scaling going on resulting in the app icons which appear in the splash screen to not appear like a perfect circle.
Chris, any idea whats going on?
Flags: needinfo?(chrislord.net)
Whiteboard: [systemsfe]
Attached image 2015-05-21-11-12-06.png
I don't see this myself - here's me launching the FM radio app on a 720p screen, I've measured the circle and it's a perfect circle.

I would suggest that perhaps the launched app icon in this screenshot is either just not circular or it's missing some of the higher-res resources and we're seeing a scaling artifact (if it's the latter, might be worth checking the CSS to make sure that it doesn't have poor-quality scaling enabled?)
Flags: needinfo?(chrislord.net)
Also, if it is a scaling artifact, perhaps because of a poor sample near the edge of the image, it might be worth checking to see if adding padding around the icon (to possibly bump up its layer size) might mitigate the issue? Not sure if that would actually work...
I think the problem is that some applications don't have needed icon size. You can see the lines 1814 and 1819 here:

https://github.com/mozilla-b2g/gaia/blob/master/apps/system/js/app_window.js#L1814

We use the maximum available size and we scale it to fit the needed size ... and that's why there are some artifacts. Maybe we need to check the apps for missing icon sizes? Chris, what do you think?
Flags: needinfo?(chrislord.net)
(In reply to Pavel Ivanov [:ivanovpavel][:pivanov] from comment #4)
> I think the problem is that some applications don't have needed icon size.
> You can see the lines 1814 and 1819 here:
> 
> https://github.com/mozilla-b2g/gaia/blob/master/apps/system/js/app_window.
> js#L1814
> 
> We use the maximum available size and we scale it to fit the needed size ...
> and that's why there are some artifacts. Maybe we need to check the apps for
> missing icon sizes? Chris, what do you think?

Sounds plausible that there are missing icon sizes and that'd certainly be the quick fix - might be worth looking at why the scaling is poor quality too though.
Flags: needinfo?(chrislord.net)
Mass update: Resolve wontfix all issues with legacy homescreens.

As of 2.6 we have a new homescreen and having these issues open is confusing. All issues will block bug 1231115 so we can use that to re-visit any of these if needed.
Blocks: 1231115
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WONTFIX
I think this was actually invalid, so won't bother changing resolution - but not a homescreen bug.
Component: Gaia::Homescreen → Gaia::System::Window Mgmt
You need to log in before you can comment on or make changes to this bug.