Closed Bug 1159299 Opened 4 years ago Closed 4 years ago

[Homescreen][Icons] The Marketplace and all Packaged app icons are displayed as rocketship icons

Categories

(Firefox OS Graveyard :: Gaia::Homescreen, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:2.5+, b2g-v2.2 unaffected, b2g-master verified)

VERIFIED FIXED
2.2 S11 (1may)
blocking-b2g 2.5+
Tracking Status
b2g-v2.2 --- unaffected
b2g-master --- verified

People

(Reporter: dharris, Assigned: kgrandon)

References

()

Details

(Keywords: regression, smoketest, Whiteboard: [3.0-Daily-Testing][systemsfe])

Attachments

(1 file)

Description:
When viewing the Markteplace Icon it will display as a rocketship icon instead of its default Icon. This issue also occurs for any packaged app that is downloaded and installed from the marketplace


Repro Steps:
1) Update a Flame to 20150428010206
2) Observe Marketplace on Homescreen> Open Marketplace app
3) Search ":Packaged" to show all packaged app
4) Install any Packaged app, such as Loqui IM or Connect A2
5) Tap home button to return to the Homescreen
 

Actual:
The Markteplace and all Packaged app icons are shown as a rocketship Icon


Expected:
All icons are properly displayed on the homescreen

Environmental Variables:
Device: Flame 3.0 (319mb)(Kitkat)(Full Flash)
Build ID: 20150428010206
Gaia: 0636405f0844bf32451a375b2d61a2b16fe33348
Gecko: caf25344f73e
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 40.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0

Repro frequency: 15/15
See attached: Logcat, Video - https://youtu.be/R7RTWWuQYTo
This issue does NOT occur on Flame 2.2

All icons are properly displayed on the homescreen

Environmental Variables:
Device: Flame 2.2 (319mb)(Kitkat)(Full Flash)
Build ID: 20150428002500
Gaia: 9f6b1b9082662ba2c14168fc66bb02b4df3141e5
Gecko: e79c19bf19bf
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 37.0 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
[Blocking Requested - why for this release]:
Visible Regression of a core feature that fails a smoke test.

Requesting a window.
blocking-b2g: --- → 3.0?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
blocking-b2g: 3.0? → 3.0+
QA Contact: ychung
b2g-inbound Regression Window:

Last Working Environmental Variables:
Device: Flame 3.0
BuildID: 20150426205758
Gaia: 196c8bb1e36d1986ecfd72b92c4b8f76268b3050
Gecko: 16f4f91aede4
Version: 40.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0

First Broken Environmental Variables:
Device: Flame 3.0
BuildID: 20150427001759
Gaia: 1966559e618575875b8cfebde3bf8165acb94be1
Gecko: 9e5d34affde5
Version: 40.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0

Last Working Gaia First Broken Gecko: Issue does NOT reproduce 
Gaia: 196c8bb1e36d1986ecfd72b92c4b8f76268b3050
Gecko: 9e5d34affde5

First Broken Gaia Last Working Gecko: Issue DOES reproduce
Gaia: 1966559e618575875b8cfebde3bf8165acb94be1
Gecko: 16f4f91aede4

https://github.com/mozilla-b2g/gaia/compare/196c8bb1e36d1986ecfd72b92c4b8f76268b3050...1966559e618575875b8cfebde3bf8165acb94be1

Caused by bug 1126709
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Contact: ychung
Josh, can you take a look at this please? This might have been caused by the landing for bug 1126709. We will need this backed out since this is a smoke test blocker.
Blocks: 1126709
Flags: needinfo?(ktucker) → needinfo?(jocheng)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Fixed now that bug 1126709 has been backed out.
Assignee: nobody → kgrandon
Status: NEW → RESOLVED
Closed: 4 years ago
Flags: needinfo?(jocheng)
Resolution: --- → FIXED
verified on local gaia build; need to wait for an official build before marking as verified.
This still occurs on :
Gaia-Rev        6e35b0948c42a4398b8a5916015de167121683a1
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/1ad65cbeb2f4
Build-ID        20150429010205
Version         40.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150429.044126
FW-Date         Wed Apr 29 04:41:37 EDT 2015
Bootloader      L1TC000118D0

Inestigating...
backout commit was : https://github.com/mozilla-b2g/gaia/commit/cc498e53ff6ef200deebebb55ec26f1d72bd1d90
Today's build is : 6e35b0948c42a4398b8a5916015de167121683a1

Looks like it didn't make it into the latest build is all.  It should be fixed in tomorrow's or the 4 pm build
QA Whiteboard: [QAnalyst-Triage+]
This issue is verified fixed on today's 3.0 nightly. See attached screenshot for observed behavior following STR.

Tested on:
Device: Flame 3.0
BuildID: 20150430010201
Gaia: db8ea705c0fd1b1684807f5a8e837bb9a36a6f96
Gecko: 4b9b12c248dc
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 40.0a1 (3.0 Master) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Target Milestone: --- → 2.2 S11 (1may)
You need to log in before you can comment on or make changes to this bug.