rss feeds appear as empty folders

VERIFIED FIXED in Firefox 40

Status

()

Firefox
Bookmarks & History
--
major
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: keeler, Assigned: mak)

Tracking

({regression})

40 Branch
Firefox 40
regression
Points:
3
Dependency tree / graph
Bug Flags:
firefox-backlog +
in-testsuite +
qe-verify +

Firefox Tracking Flags

(firefox40 verified)

Details

Attachments

(1 attachment)

I (used to) have a number of bookmarked RSS feeds. Today after updating to the latest nightly, they were turned into empty directories. Furthermore, I can't add any new RSS feeds (when viewing a feed, the "subscribe now" button does nothing).
It appears that the "subscribe now" button not working is e10s-related. However, even after viewing a feed in a non-e10s window and successfully clicking "subscribe now", the feed doesn't appear anywhere in my bookmarks.
(Assignee)

Comment 2

3 years ago
I see the same, it's not e10s related.
Looks like a regression in bookmarks, I will investigate it later.
Component: General → Bookmarks & History
Keywords: regression, regressionwindow-wanted
(Assignee)

Updated

3 years ago
Points: --- → 3
Flags: qe-verify+
Flags: in-testsuite?
Flags: firefox-backlog+
OS: Linux → All
Hardware: x86_64 → All
(Assignee)

Updated

3 years ago
Duplicate of this bug: 1159381
(Assignee)

Updated

3 years ago
Assignee: nobody → mak77
Blocks: 1094900
Status: NEW → ASSIGNED
Keywords: regressionwindow-wanted

Updated

3 years ago
Iteration: --- → 40.3 - 11 May
(Assignee)

Comment 4

3 years ago
Created attachment 8598942 [details] [diff] [review]
patch v1

I should have added a test when you told me to :/
Attachment #8598942 - Flags: review?(ttaubert)
Attachment #8598942 - Flags: review?(ttaubert) → review+
(Assignee)

Updated

3 years ago
Duplicate of this bug: 1159508
https://hg.mozilla.org/mozilla-central/rev/d8590ff0898f
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
status-firefox40: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 40
This seems to be only fixed on Mac OS X, using latest Nightly, build ID: 20150503030209.

On Windows 7 64-bit, Windows 8.1 64-bit and Ubuntu 14.04 64-bit, the user can now view the existing feeds but it's unable to add new ones.

After clicking "subscribe now", nothing happens and the following console errors are thrown:
NS_ERROR_NOT_AVAILABLE: Component returned failure code: 0x80040111 (NS_ERROR_NOT_AVAILABLE) [nsIPrefBranch.setCharPref] FeedWriter.js:1275:0
(Assignee)

Comment 9

3 years ago
(In reply to Cornel Ionce [QA] from comment #8)
> On Windows 7 64-bit, Windows 8.1 64-bit and Ubuntu 14.04 64-bit, the user
> can now view the existing feeds but it's unable to add new ones.
> 
> After clicking "subscribe now", nothing happens and the following console
> errors are thrown:
> NS_ERROR_NOT_AVAILABLE: Component returned failure code: 0x80040111
> (NS_ERROR_NOT_AVAILABLE) [nsIPrefBranch.setCharPref] FeedWriter.js:1275:0

This bug is only about broken existing livemarks... if there's a bug in adding livemarks, it's somewhere else, for example it might be an e10s issue:

https://bugzilla.mozilla.org/buglist.cgi?quicksearch=feed%20e10s&list_id=12227754

Indeed it works properly in a non-e10s window...
(Assignee)

Comment 10

3 years ago
so basically, comment 1 here has nothing to do with comment 0... it needs a separate bug, but might be one of the known e10s bugs already.
(Assignee)

Comment 11

3 years ago
let me clarify the title.
Summary: rss feed functionality is broken → rss feed appear as empty folders
(Assignee)

Updated

3 years ago
Summary: rss feed appear as empty folders → rss feeds appear as empty folders
(Assignee)

Comment 12

3 years ago
note that I currently cannot find an explicit bug about subscribe to feed being broken on e10s, the bugs above look like minor downsides.
Could be bug 1109714, so I'd suggest to ask there and eventually file a separate bug if needed.
Yup, that indeed seems to be bug 1109714, as the subscribe button is not working on e10s and the UI will be changed.
Thanks for clarifying this!
Status: RESOLVED → VERIFIED
status-firefox40: fixed → verified

Updated

3 years ago
Depends on: 1182046
(Assignee)

Updated

3 years ago
Flags: in-testsuite? → in-testsuite+
You need to log in before you can comment on or make changes to this bug.