Closed Bug 1159552 Opened 5 years ago Closed 5 years ago

[bluetooth2] Clear local {services|characteristics|descriptors} arrays when handling discovering procedures.

Categories

(Firefox OS Graveyard :: Bluetooth, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(firefox40 fixed)

RESOLVED FIXED
2.2 S11 (1may)
Tracking Status
firefox40 --- fixed

People

(Reporter: brsun, Assigned: brsun)

References

Details

Attachments

(1 file, 1 obsolete file)

|BluetoothGatt.services| [1] has duplicated services if |BluetoothGatt.discoverServices()| [2] is called more than once.

|BluetoothGatt.mServices| might need to be cleared in |BluetoothGatt::HandleServicesDiscovered()| [3] in Gecko.


[1] https://wiki.mozilla.org/B2G/Bluetooth/WebBluetooth-v2/BluetoothGatt#discoverServices.28.29
[2] https://wiki.mozilla.org/B2G/Bluetooth/WebBluetooth-v2/BluetoothGatt#services
[3] https://dxr.mozilla.org/mozilla-central/source/dom/bluetooth/bluetooth2/BluetoothGatt.cpp#279
Duplicate of this bug: 1159555
Summary: [bluetooth2] |BluetoothGatt.services| has duplicated services if |BluetoothGatt.discoverServices()| is called more than once. → [bluetooth2] Clear local {services|characteristics|descriptors} arrays when handling discovering procedures.
Attachment #8599292 - Flags: review?(joliu)
Comment on attachment 8599292 [details] [diff] [review]
bug1159552_gatt_clear_local_arrays_while_discovering.patch

Review of attachment 8599292 [details] [diff] [review]:
-----------------------------------------------------------------

LGTM.

Thanks for fixing this bug!
Attachment #8599292 - Flags: review?(joliu) → review+
Assignee: nobody → brsun
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/5e40e02cb872
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → 2.2 S11 (1may)
Blocks: 1165848
You need to log in before you can comment on or make changes to this bug.