[FFOS7715 v2.1s] [dolphin&flame] The font become blurred when playing video in browser.

RESOLVED DUPLICATE of bug 1144534

Status

()

Core
Layout
--
major
RESOLVED DUPLICATE of bug 1144534
3 years ago
2 years ago

People

(Reporter: lin.hui@spreadtrum.com, Unassigned)

Tracking

({ux-userfeedback})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: gfx-noted)

Attachments

(4 attachments)

(Reporter)

Description

3 years ago
Defect description:
  The font become blurred when playing video in browser.

Steps to reproduce:
  1. Open browser, visit "dailymotion.com" site;
  3. Click one video's thumbnail to open the video displayed page,
  4. sliding the page to the bottom, loading more videos to displayed;
  5. Now back to the top, and touch the video to playing;
  6. Once the video starts to play, the font become blurred until the video play ended, this is bad UX.
(Reporter)

Comment 1

3 years ago
Dear vance:

The font become blurred when playing video in browser, this may take bad UX, I know this issue is caused by Async Pan/Zoom mechanism, when I disabled this mechanism, the font will not become blurred, but when setting the Async Pan/Zoom disabled, other function will be affected, so I'd like you help to find someone investigate this issue. 

BTW, I have captured a video about this issue, please watch it and see the detail steps, please visit the following path to downloading the video:
ftp://ftp.spreadtrum.com/for_sprd_mozilla/Mozilla_bug1159564/  file name: Font_blurred.3gp

Thank you.
Flags: needinfo?(vchen)
Well ironically I think we deliberately make the font blurred for better user experience during scrolling...

might need UI team to better explain this...
Flags: needinfo?(vchen) → needinfo?(lin.hui)
Keywords: ux-userfeedback
(Reporter)

Comment 3

3 years ago
Created attachment 8599085 [details]
Blurred_font.png

When video is playing, you can see the font blurred.
(Reporter)

Comment 4

3 years ago
Created attachment 8599087 [details]
No_blurred.png

When the video play ended, you can see the font recovery to clear.
Flags: needinfo?(lin.hui)
(Reporter)

Comment 5

3 years ago
(In reply to lin.hui@spreadtrum.com from comment #3)
> Created attachment 8599085 [details]
> Blurred_font.png
> 
> When video is playing, you can see the font blurred.
BTW, when video playing, I didn't do scrolling operation.
Hi Hui Lin -

Sorry my bad, I thought you were talking about another blur issue.

However I check again the video, also I try to reproduce this issue myself. Still I cannot see any obvious blur in the screen. I am testing with B-Mobile/Sprocomm device. Is this issue much obvious on original SPRD 7715 device(or larger screen device such as Flame)?

But honestly I find it is quite hard to tell what is the blur from your video as well...
Flags: needinfo?(lin.hui)
(Reporter)

Comment 7

3 years ago
(In reply to Vance Chen [:vchen][vchen@mozilla.com] from comment #6)
> Hi Hui Lin -
> 
> Sorry my bad, I thought you were talking about another blur issue.
> 
> However I check again the video, also I try to reproduce this issue myself.
> Still I cannot see any obvious blur in the screen. I am testing with
> B-Mobile/Sprocomm device. Is this issue much obvious on original SPRD 7715
> device(or larger screen device such as Flame)?
> 
> But honestly I find it is quite hard to tell what is the blur from your
> video as well...
According the two attachments(Blurred_font.png and No_blurred.png), you can obvious find that the font is different, when playing video, the font has ghost(chóng yǐng 重影), our eyes look this uncomfortable.

Thank you.
Flags: needinfo?(lin.hui)
OK now I can reproduce this one in Flame as well. However, what puzzles me is this issue cannot be reproduced with similar steps in Youtube. Seems like it can only be reproduced in DailyMotion...

Hi Shawn, Evelyn, could you kindly advice who can help to check this issue?

Thanks
Flags: needinfo?(sku)
Flags: needinfo?(ehung)

Comment 9

3 years ago
Hi Mason:
 Per comment 1, it looks like issue is gone if we disable APZ.
We can also repo. this issue on flame device.

Could you please help check this problem first?

Thanks!!
Flags: needinfo?(sku)
Flags: needinfo?(mchang)
Flags: needinfo?(ehung)
Flags: needinfo?(mchang) → needinfo?(bugmail.mozilla)
Whiteboard: gfx-noted
It appears to be giant layer that doesn't get tiled, so we draw it at lower resolution and then scale it up, causing the blurriness. In the layer dump I see a preScale=[1,2] similar to what tn reported in bug 1144534. I'll investigate a bit more, leaving ni on me for now.
status-b2g-master: --- → affected
Created attachment 8599477 [details] [diff] [review]
ugly ugly hack

This has something to do with wrapping preserve-3d transforms, I think. When I traced through the code, after starting the video the childrenVisible rect at [1] becomes ginormous, causing the aVisibleRect passed to ChooseScaleAndSetTransform to also become ginormous. This exceeds the max layer size and then causes the pre-scale to be applied.

Tracing backwards from there, the big childrenVisible rect was coming from an nsDisplayTransform which was coming from [2]. It looks like to me that |aTemp| there collects a lot of items before it finally gets flushed, and so the nsDisplayTransform that holds all of those items has a super-tall childrenVisible rect. I stuck in the attached wonderful hack which seemed to fix the problem, confirming my diagnosis. I don't know enough about this code to know if this is the root-cause or not, though. From a cursory reading of this code it doesn't like it would be a problem to split one nsDisplayTransform into a bunch but I don't really know. Somebody who knows the preserve-3d code should look into this.

[1] http://mxr.mozilla.org/mozilla-central/source/layout/base/FrameLayerBuilder.cpp?rev=9da538675a2d#4755
[2] http://mxr.mozilla.org/mozilla-central/source/layout/generic/nsFrame.cpp?rev=9da538675a2d#1799
Flags: needinfo?(bugmail.mozilla)
Component: Gaia → Layout
Product: Firefox OS → Core
Hi kats, is the patch from comment 11 in gecko now?  (Because I can't see the blurred text when I tried the STR) if so we'll verify to see whether the fix is good.
Flags: needinfo?(bugmail.mozilla)
No, I don't think that change ever landed. As far as I know the underlying problem here has not been fixed in gecko. If this issue is no longer occurring we can close it as WFM.
Flags: needinfo?(bugmail.mozilla)
adding qawanted to make sure this bug doesn't repro in aries/flame.
Keywords: qawanted
The bug can be reproduced on latest build of Flame master & Aries master by the STR in comment 0.

See attachment:Falme master.png

Reproduce rate: 5/5

Device: Flame master (Affected)
Build ID               20150723160204
Gaia Revision          ec2199b324304d3678b6a98a08a31bdc13c9e984
Gaia Date              2015-07-23 17:16:25
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/cb8bdb8ffaef
Gecko Version          42.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150723.193607
Firmware Date          Thu Jul 23 19:36:19 EDT 2015
Bootloader             L1TC000118D0

Device: Aries master (Affected)
Build ID               20150723024716
Gaia Revision          f04fdbfa1943dddeab8ecd1299a76ab56e590d00
Gaia Date              2015-07-22 18:44:09
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/2ddec2dedced
Gecko Version          42.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20150723.023231
Firmware Date          Thu Jul 23 02:32:39 UTC 2015
Bootloader             s1
Flags: needinfo?(npark)
Created attachment 8638443 [details]
Falme master.png
QA Whiteboard: [MGSEI-Triage+]
Keywords: qawanted
There have been many similar bugs reported; I'm going to dupe this to the master bug that I'm collapsing everything into.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1144534
clearing ni? per Comment 17
Flags: needinfo?(npark)
status-b2g-master: affected → ---
See Also: bug 1144534
You need to log in before you can comment on or make changes to this bug.