[Callscreen] Use the telephony's audio channel api to make telephony channel manageable by System app

RESOLVED FIXED

Status

Firefox OS
Gaia::Dialer
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: dkuo, Assigned: dkuo)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-master fixed)

Details

Attachments

(1 attachment)

46 bytes, text/x-github-pull-request
gsvelto
: review+
Details | Review | Splinter Review
(Assignee)

Description

3 years ago
To enable the new audio channel service in gaia, we need to let System app know which app is using the telephony channel, because the telephony channel does not use media element to produce sounds, there will be no event when the telephony channel activates.

Bug 1129882 will introduce a new api for telephony's audio channel, it's:

|Telephony.ownAudioChannel()|

So after/before the api landed, we need to call it in Callscreen app so that the System app is able to manage the telephony audio channel.
(In reply to Dominic Kuo [:dkuo] from comment #0)
> So after/before the api landed, we need to call it in Callscreen app so that
> the System app is able to manage the telephony audio channel.

Can you elaborate when this call has to be made? At the beginning of a call?
(Assignee)

Comment 2

3 years ago
(In reply to Gabriele Svelto [:gsvelto] from comment #1)
> Can you elaborate when this call has to be made? At the beginning of a call?

The main goal to call this api is to let the System's audio channel service knows about Callscreen will be using the telephony channel, we can say it's the initialization of audio channel. So if possible, it's better to do it before a call actually comes, not to wait the ril state changes. But I don't know the Callscreen code well, you guys should be able to make better judgement than me, if there are concerns, like performance regression.
I think this should be implemented before landing the new architecture of the audio channel.
Since the JS can detect whether the specific function exists, if it doesn't, we can ignore it.
Blocks: 1113086
No longer depends on: 1129882
See Also: → bug 1129882
(Assignee)

Updated

3 years ago
Assignee: nobody → dkuo
(Assignee)

Comment 4

3 years ago
Created attachment 8616605 [details] [review]
patch

Gabriele, would you please review this? thanks.
Attachment #8616605 - Flags: review?(gsvelto)
Comment on attachment 8616605 [details] [review]
patch

As per comment 3 there's no problem in landing this as is.
Attachment #8616605 - Flags: review?(gsvelto) → review+
(Assignee)

Comment 6

3 years ago
Thanks Gabriele :)

master: https://github.com/mozilla-b2g/gaia/commit/314cc9b2b56cfef14875101f2350aa3be15e7cae
Status: NEW → RESOLVED
Last Resolved: 3 years ago
status-b2g-master: --- → fixed
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.