Imap: Sent, Draft and Template do not get/can not be created

VERIFIED DUPLICATE of bug 27002

Status

MailNews Core
Networking: IMAP
--
major
VERIFIED DUPLICATE of bug 27002
16 years ago
9 years ago

People

(Reporter: Sam Rogers, Assigned: Cavin Song)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.6+) Gecko/20011214
BuildID:    2001121412

I am using Exim and Cyrus Imap.

After I created a Imap account pointing to my Imap server on my system. I
noticed that it only created a Trash folder. It did not create a Drafts, Sent or
Template folder like the other accounts.

When I try and send a message if comes up with a error message:

Copying message to Sent folder:

The current command line did not succeed. The Mail server responded:
Permission denied.

It then proccees to send the message anyway, but does not save it to the Sent
folder.


When I try and Save a mail message it says:

Copying message to Drafts folder:

The current command line did not succeed. The Mail server responded:
Permission denied.

I then cancel and try and click on Save button again and nothing happens. I then
close the window and the message comes asking if I want to save the message. If
I say yes I get the same above message.

If I use Netscape 4.76 it save it to the drafts folder under the local folders.
So I think Exim and Imap are working ok.

I do not get a option to save a message as a template.

I tried to search Bugzilla for this type of error but it froze one time and blew
it away a second.

Reproducible: Always
Steps to Reproduce:
1.Just create a Imap account.
2.remove the Imap account
3.Recreate it again.

Actual Results:  same

Comment 1

16 years ago
looks like your inbox doesn't contain these folders/and are not available for
creation on your imap server..  And chances are your local folders are not being
recognized.  which is when sent ones can be copied to, and if you imap account
on the server doesn't have a sent folder, you will probably see that cannot
save/copy to send folder.

I've seen the last one reported in newsgroups several times recently.

Comment 2

16 years ago
Cavin has worked on similar code before - sounds like we're failing to create
the Sent folder on the imap server in the cyrus case.

This page describes how to generate an imap protocol log of a session where you
attempt to send a message:
http://www.mozilla.org/quality/mailnews/mail-troubleshoot.html#imap

It would be useful for you to try this, and attach the log (looking through it
to make sure there's nothing you don't want public. If that's not possible, you
could send me (bienvenu@netscape.com) the log and I can look at it with Cavin.
My guess is that we're not trying to put the Sent folder under the inbox.
Assignee: bienvenu → cavin
Component: Mail Database → Networking - IMAP
(Reporter)

Comment 3

16 years ago
To Dennis,

I did go and read the newsgroup for this kind of bug. And did try their
suggestions even though they were not using Exim and were using UW Imap. I use
Cyrus Imap which handles it's folders in a database and not flat file format. I
can create a Sent and Drafts folder under Inbox, as well as anyother folder. But
that does no good as I still get the same error message when trying to save to
Drafts or Send a message. Mozilla does not reconize them as System folders. That
is why I thought it might be a Mozilla error after I spent a whole day banging
my head agaist the wall on this. I do try and research before I submit a bug
report, if I know where to look.

To bienvenu

Thank you for the suggestion and I will try it when I get back this evening. I
also double checked the /var/log/imap.log and still nothing is in it.

Regards,

      Sam Rogers.
(Reporter)

Comment 4

16 years ago
 bienvenu,

I did run Mozilla Imap mail with the debug settings. Could it be a permissions
problem with a socket, file or directory? It also seems to create two other
files and so here they are:

1st file: [srogers@home1 /tmp]$ more nscopy-1.tmp
FCC: imap://srogers@home1.mediaratings.tv/Sent
Message-ID: <3C225DF4.90505@mediaratings.tv>
Date: Thu, 20 Dec 2001 13:53:56 -0800
From: "Samuel A. Rogers" <srogers@mediaratings.tv>
X-Mozilla-Draft-Info: internal/draft; vcard=0; receipt=0; uuencode=0
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.6+) Gecko/20011214
X-Accept-Language: en-us
MIME-Version: 1.0
To: "Samuel A. Rogers" <srogers@mediaratings.tv>
Subject: Re: local-test8
References: <E16GUHw-0000cs-00@home1.mediaratings.tv>
Content-Type: text/html; charset=us-ascii
Content-Transfer-Encoding: 7bit
 
<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html>
<head>
  <title></title>
</head>
<body>
Samuel A. Rogers wrote:<br>
<blockquote type="cite" cite="mid:E16GUHw-0000cs-00@home1.mediaratings.tv">
  <pre wrap="">         local-test8<br><br><br>           
:-)<br><br><br><br><br></pre>
  </blockquote>
&nbsp;&nbsp;&nbsp; Re: local -test8<br>
  <blockquote type="cite" cite="mid:E16GUHw-0000cs-00@home1.mediaratings.tv">
    <pre wrap=""><br></pre>
    </blockquote>
    </body> 
    </html>

2nd file: [srogers@home1 /tmp]$ cat nsmail-1.eml
Message-ID: <3C225DF4.90505@mediaratings.tv>
Date: Thu, 20 Dec 2001 13:53:56 -0800
From: "Samuel A. Rogers" <srogers@mediaratings.tv>
X-Mozilla-Draft-Info: internal/draft; vcard=0; receipt=0; uuencode=0
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.6+) Gecko/20011214
X-Accept-Language: en-us
MIME-Version: 1.0
To: "Samuel A. Rogers" <srogers@mediaratings.tv>
Subject: Re: local-test8
References: <E16GUHw-0000cs-00@home1.mediaratings.tv>
Content-Type: text/html; charset=us-ascii
Content-Transfer-Encoding: 7bit
 
<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html>
<head>
  <title></title>
</head>
<body>
Samuel A. Rogers wrote:<br>
<blockquote type="cite" cite="mid:E16GUHw-0000cs-00@home1.mediaratings.tv">
  <pre wrap="">         local-test8<br><br><br>           
:-)<br><br><br><br><br></pre>
  </blockquote>
&nbsp;&nbsp;&nbsp; Re: local -test8<br>
  <blockquote type="cite" cite="mid:E16GUHw-0000cs-00@home1.mediaratings.tv">
    <pre wrap=""><br></pre>
    </blockquote>
    </body>
    </html>

3rd file: [srogers@home1 /tmp]$ cat mozillia_bug.log
4101[8d037f8]: home1.mediaratings.tv:NA:CreateNewLineFromSocket: * OK
home1.mediaratings.tv Cyrus IMAP4 v2.0.9 server ready
4101[8d037f8]: home1.mediaratings.tv:NA:SendData: 1 capability
4101[8d037f8]: home1.mediaratings.tv:NA:CreateNewLineFromSocket: * CAPABILITY
IMAP4 IMAP4rev1 ACL QUOTA LITERAL+ NAMESPACE UIDPLUS ID NO_ATOMIC_RENAME
UNSELECT MULTIAPPEND SORT THREAD=ORDEREDSUBJECT THREAD=REFERENCES IDLE
AUTH=DIGEST-MD5 AUTH=CRAM-MD5 X-NETSCAPE
4101[8d037f8]: home1.mediaratings.tv:NA:CreateNewLineFromSocket: 1 OK Completed
4101[8d037f8]: home1.mediaratings.tv:NA:SendData: Logging suppressed for this
command (it probably contained authentication information)
4101[8d037f8]: home1.mediaratings.tv:NA:CreateNewLineFromSocket: 2 OK User logged in
4101[8d037f8]: home1.mediaratings.tv:A:SendData: 3 namespace
4101[8d037f8]: home1.mediaratings.tv:A:CreateNewLineFromSocket: * NAMESPACE
(("INBOX." ".")) NIL (("" "."))
4101[8d037f8]: home1.mediaratings.tv:A:CreateNewLineFromSocket: 3 OK Completed
4101[8d037f8]: home1.mediaratings.tv:A:SendData: 4 lsub "" "INBOX.*"
4101[8d037f8]: home1.mediaratings.tv:A:CreateNewLineFromSocket: * LSUB () "."
"INBOX.Error"
4101[8d037f8]: home1.mediaratings.tv:A:CreateNewLineFromSocket: * LSUB () "."
"INBOX.Trash"
4101[8d037f8]: home1.mediaratings.tv:A:CreateNewLineFromSocket: 4 OK Completed
4101[8d037f8]: home1.mediaratings.tv:A:SendData: 5 lsub "" "*"
4101[8d037f8]: home1.mediaratings.tv:A:CreateNewLineFromSocket: * LSUB () "."
"INBOX.Error"
4101[8d037f8]: home1.mediaratings.tv:A:CreateNewLineFromSocket: * LSUB () "."
"INBOX.Trash"
4101[8d037f8]: home1.mediaratings.tv:A:CreateNewLineFromSocket: 5 OK Completed
4101[8d037f8]: home1.mediaratings.tv:A:SendData: 6 list "" "INBOX"
4101[8d037f8]: home1.mediaratings.tv:A:CreateNewLineFromSocket: * LIST () "."
"INBOX"
4101[8d037f8]: home1.mediaratings.tv:A:CreateNewLineFromSocket: 6 OK Completed
4101[8d037f8]: home1.mediaratings.tv:A:SendData: 7 select "INBOX"
4101[8d037f8]: home1.mediaratings.tv:A:CreateNewLineFromSocket: * FLAGS
(\Answered \Flagged \Draft \Deleted \Seen) 4101[8d037f8]:
home1.mediaratings.tv:A:CreateNewLineFromSocket: * OK [PERMANENTFLAGS (\Answered
\Flagged \Draft \Deleted \Seen \*)]
4101[8d037f8]: home1.mediaratings.tv:A:CreateNewLineFromSocket: * 2 EXISTS
4101[8d037f8]: home1.mediaratings.tv:A:CreateNewLineFromSocket: * 0 RECENT
4101[8d037f8]: home1.mediaratings.tv:A:CreateNewLineFromSocket: * OK
[UIDVALIDITY 1008720257]
4101[8d037f8]: home1.mediaratings.tv:A:CreateNewLineFromSocket: * OK [UIDNEXT 22]
4101[8d037f8]: home1.mediaratings.tv:A:CreateNewLineFromSocket: 7 OK
[READ-WRITE] Completed
4101[8d037f8]: home1.mediaratings.tv:S-INBOX:SendData: 8 getacl "INBOX"
4101[8d037f8]: home1.mediaratings.tv:S-INBOX:CreateNewLineFromSocket: * ACL
INBOX srogers lrswipcda
4101[8d037f8]: home1.mediaratings.tv:S-INBOX:CreateNewLineFromSocket: 8 OK Completed
4101[8d037f8]: home1.mediaratings.tv:S-INBOX:SendData: 9 UID fetch 1:* (FLAGS)
4101[8d037f8]: home1.mediaratings.tv:S-INBOX:CreateNewLineFromSocket: * 1 FETCH
(FLAGS (\Answered \Seen) UID 1)
4101[8d037f8]: home1.mediaratings.tv:S-INBOX:CreateNewLineFromSocket: * 2 FETCH
(FLAGS (\Seen) UID 5)
4101[8d037f8]: home1.mediaratings.tv:S-INBOX:CreateNewLineFromSocket: 9 OK Completed
4101[8d037f8]: home1.mediaratings.tv:S-INBOX:SendData: 10 UID fetch 1 (UID
RFC822.SIZE BODY[])
4101[8d037f8]: home1.mediaratings.tv:S-INBOX:CreateNewLineFromSocket: * 1 FETCH
(UID 1 RFC822.SIZE 526 BODY[] {526}4101[8d037f8]:
home1.mediaratings.tv:S-INBOX:STREAM:OPEN Size: 526: Begin Message Download Stream
4101[8d037f8]: home1.mediaratings.tv:S-INBOX:CreateNewLineFromSocket:
Return-Path: <cyrus@home1.mediaratings.tv>
4101[8d037f8]: home1.mediaratings.tv:S-INBOX:CreateNewLineFromSocket: X-Sieve:
cmu-sieve 2.0
4101[8d037f8]: home1.mediaratings.tv:S-INBOX:CreateNewLineFromSocket:
Return-path: <srogers@mediaratings.tv>
4101[8d037f8]: home1.mediaratings.tv:S-INBOX:CreateNewLineFromSocket: Received:
from srogers by home1.mediaratings.tv with local (Exim 3.22 #1)
4101[8d037f8]: home1.mediaratings.tv:S-INBOX:CreateNewLineFromSocket:   id
16GUHw-0000cs-00
4101[8d037f8]: home1.mediaratings.tv:S-INBOX:CreateNewLineFromSocket:   for
srogers@home1.mediaratings.tv; Tue, 18 Dec 2001 16:08:48 -0800
4101[8d037f8]: home1.mediaratings.tv:S-INBOX:CreateNewLineFromSocket: To:
srogers@home1.mediaratings.tv
4101[8d037f8]: home1.mediaratings.tv:S-INBOX:CreateNewLineFromSocket: Subject:
local-test8
4101[8d037f8]: home1.mediaratings.tv:S-INBOX:CreateNewLineFromSocket:
Message-Id: <E16GUHw-0000cs-00@home1.mediaratings.tv>
4101[8d037f8]: home1.mediaratings.tv:S-INBOX:CreateNewLineFromSocket: From:
"Samuel A. Rogers" <srogers@mediaratings.tv>
4101[8d037f8]: home1.mediaratings.tv:S-INBOX:CreateNewLineFromSocket: Date: Tue,
18 Dec 2001 16:08:48 -0800
4101[8d037f8]: home1.mediaratings.tv:S-INBOX:CreateNewLineFromSocket:
4101[8d037f8]: home1.mediaratings.tv:S-INBOX:CreateNewLineFromSocket:
4101[8d037f8]: home1.mediaratings.tv:S-INBOX:CreateNewLineFromSocket:
4101[8d037f8]: home1.mediaratings.tv:S-INBOX:CreateNewLineFromSocket:
4101[8d037f8]: home1.mediaratings.tv:S-INBOX:CreateNewLineFromSocket:
4101[8d037f8]: home1.mediaratings.tv:S-INBOX:CreateNewLineFromSocket:          
local-test8
4101[8d037f8]: home1.mediaratings.tv:S-INBOX:CreateNewLineFromSocket:
4101[8d037f8]: home1.mediaratings.tv:S-INBOX:CreateNewLineFromSocket:
4101[8d037f8]: home1.mediaratings.tv:S-INBOX:CreateNewLineFromSocket:          
   :-)
4101[8d037f8]: home1.mediaratings.tv:S-INBOX:CreateNewLineFromSocket:
4101[8d037f8]: home1.mediaratings.tv:S-INBOX:CreateNewLineFromSocket:
4101[8d037f8]: home1.mediaratings.tv:S-INBOX:CreateNewLineFromSocket:
4101[8d037f8]: home1.mediaratings.tv:S-INBOX:CreateNewLineFromSocket:
4101[8d037f8]: home1.mediaratings.tv:S-INBOX:CreateNewLineFromSocket:
4101[8d037f8]: home1.mediaratings.tv:S-INBOX:CreateNewLineFromSocket: )
4101[8d037f8]: home1.mediaratings.tv:S-INBOX:STREAM:CLOSE: Normal Message End
Download Stream
4101[8d037f8]: home1.mediaratings.tv:S-INBOX:CreateNewLineFromSocket: 10 OK
Completed
4101[8d037f8]: home1.mediaratings.tv:S-INBOX:SendData: 11 list "" "Drafts"
4101[8d037f8]: home1.mediaratings.tv:S-INBOX:CreateNewLineFromSocket: 11 OK
Completed
4101[8d037f8]: home1.mediaratings.tv:S-INBOX:SendData: 12 create "Drafts"
4101[8d037f8]: home1.mediaratings.tv:S-INBOX:CreateNewLineFromSocket: 12 NO
Permission denied
4101[8d037f8]: home1.mediaratings.tv:S-INBOX:SendData: 13 list "" "Drafts"
4101[8d037f8]: home1.mediaratings.tv:S-INBOX:CreateNewLineFromSocket: 13 OK
Completed
4101[8d037f8]: home1.mediaratings.tv:S-INBOX:SendData: 14 create "Drafts"
4101[8d037f8]: home1.mediaratings.tv:S-INBOX:CreateNewLineFromSocket: 14 NO
Permission denied
4101[8d037f8]: home1.mediaratings.tv:S-INBOX:SendData: 15 noop
4101[8d037f8]: home1.mediaratings.tv:S-INBOX:CreateNewLineFromSocket: 15 OK
Completed
4101[8d037f8]: home1.mediaratings.tv:S-INBOX:SendData: 16 UID fetch 6:* (FLAGS)
4101[8d037f8]: home1.mediaratings.tv:S-INBOX:CreateNewLineFromSocket: * 2 FETCH
(FLAGS (\Seen) UID 5)
4101[8d037f8]: home1.mediaratings.tv:S-INBOX:CreateNewLineFromSocket: 16 OK
Completed


(Assignee)

Comment 5

16 years ago
Sounds like a dup of bug 27002. Karen, can you verify it?
QA Contact: esther → huang

Comment 6

16 years ago
yes, seems like a dup. The problem is that we're not respecting the namespace
when creating the online folders like drafts/sent etc.

Comment 7

16 years ago
Yes. Based on my comments on 2001-08-03 14:50 of bug 27002:

>Because of bug 23625 fix (Copies & Folder point to server now), so this problem 
>actually apply to both Migrated & New profile......

Resolved as dup of bug 27002





*** This bug has been marked as a duplicate of 27002 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 8

16 years ago
Verified.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.