[SIM Prompt] Text Cursor is revealed on SIM Prompt screen on unlock before UI is revealed if text was leftover

RESOLVED WONTFIX

Status

Firefox OS
Gaia::System
RESOLVED WONTFIX
3 years ago
3 months ago

People

(Reporter: oliverthor, Assigned: gduan)

Tracking

({polish})

unspecified
ARM
Gonk (Firefox OS)
polish

Firefox Tracking Flags

(b2g-v2.0 unaffected, b2g-v2.1 unaffected, b2g-v2.2 affected, b2g-master affected)

Details

(Whiteboard: [3.0-Daily-Testing], URL)

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Created attachment 8599471 [details]
logcat_20150429_1241.txt

Description:
When a user unlocks their phone into a 'Enter SIM Pin' prompt, they may observe that they can type characters and then lock their device. Upon unlocking, the characters will remain in the prompt. This design leads to a text cursor being revealed before the UI is revealed briefly causing a visual fault.

Repro Steps:
1) Update a Flame to 20150429010205
2) Enable a SIM Pin in Settings
3) Enable/Disable Airplane Mode
4) Observe SIM Pin prompt, type in characters: don't confirm yet.
5) Lock phone with characters typed in Pin prompt.
6) Unlock phone and observe UI as SIM Prompt is revealed.

Actual:
Text Cursor Carat is revealed before 'Enter SIM Prompt' is when characters are left over.

Expected:
Text Cursor Carat is not revealed until user has gained control of the text field, or keyboard is revealed.


Environmental Variables:
-------------------------------------------------------

Device: Flame 3.0
Build ID: 20150429010205
Gaia: 6e35b0948c42a4398b8a5916015de167121683a1
Gecko: 1ad65cbeb2f4
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 40.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0

Device: Flame 2.2
BuildID: 20150429002501
Gaia: 1b7aa7e60788668ed09abf76022dfa231dbe88d4
Gecko: d38ff4717f39
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
-------------------------------------------------------

Issue DOES NOT REPRO on 2.1 or 2.0 for flame devices:
Results: Text Cursor Carat does not display, text editting fields not avaliable.
Device: Flame 2.1
BuildID: 20150429001202
Gaia: 9fda4aec7f9495a27a335ccaf3b1a4dc9c4c6db0
Gecko: 38ab00c01159
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 34.0 (2.1) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Device: Flame 2.0
BuildID: 20150429000200
Gaia: 84898cadf28b1a1fcd03b726cff658de470282f0
Gecko: b154e9aae020
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 32.0 (2.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
-------------------------------------------------------

Repro frequency: 5/5
See attached: 
video- https://youtu.be/YaARBMzibbc
logcat
(Reporter)

Updated

3 years ago
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
I would have blocked in an earlier stage since this is the first screen a user sees when the phone starts.
George, can you take a look?
Flags: needinfo?(gduan)
Keywords: polish
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(pbylenga)
Created attachment 8600802 [details] [review]
[gaia] cctuan:1159866 > mozilla-b2g:master
Hi Nelson, 

I think the root cause is, we focus on the input element earlier than the fully hiding of lockscreen, but on my device, the caret and SIM Prompt screen show almost together without my patch.

Could you check my patch before my landing?
Assignee: nobody → gduan
Flags: needinfo?(gduan) → needinfo?(onelson)
(Reporter)

Comment 4

3 years ago
Fix looks good, issue appears fixed. Marking as resolved, will follow up with verification when pull request lands in master.
Results: Text Selection Carat appears at SIM Prompt after user has gained focus of input elements.

Environmental Variables:
Device: Flame 3.0
BuildID: 20150504010202
Gaia: d004962fbe2892e97cecd311624a4dfbfada39f1
Gecko: dc5f85980a82
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 40.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0

Repro: 5/5 passing
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(onelson)
Resolution: --- → FIXED
Comment on attachment 8600802 [details] [review]
[gaia] cctuan:1159866 > mozilla-b2g:master

Hi Alive,
could you review this patch?

I put the -deactivated event after lockscreen-appclose instead of appclosed, because the latter would cause significant delay between lockscreen fully hidden and keyboard's displaying. So, I use appclose, and the result seems good and is verified.
Attachment #8600802 - Flags: review?(alive)
We don't close bugs if the code hasn't landed.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Comment on attachment 8600802 [details] [review]
[gaia] cctuan:1159866 > mozilla-b2g:master

I wonder we need to correct the timing to call this.topMostUI.setHierarchy(true) in HierarchyManager to make sure it's happening after 'deactivated' event instead of 'deactivating' event. Now it's calling for both timing. But for this bug it's fine not touching the logic.
Attachment #8600802 - Flags: review?(alive) → review+
Keywords: checkin-needed

Updated

3 years ago
Keywords: checkin-needed

Updated

3 years ago
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago3 years ago
Resolution: --- → FIXED
Depends on: 1163680
revert this patch due to bug 1163680 ,
https://github.com/mozilla-b2g/gaia/commit/1dc6e72dcb9f34a145557eb478b1f62727f8ad0c
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 10

3 months ago
Firefox OS is not being worked on
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago3 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.