If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[l10n][Notifications]Serbian Latin:The " Please turn off wifi airplane mode to enable Usages" is truncated.

VERIFIED FIXED

Status

Mozilla Localizations
sr / Serbian
VERIFIED FIXED
2 years ago
2 years ago

People

(Reporter: Elie, Unassigned)

Tracking

(Blocks: 1 bug)

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.1 verified, b2g-v2.2 verified)

Details

(Whiteboard: LocRun2.2,)

Attachments

(4 attachments)

(Reporter)

Description

2 years ago
[1.Description]:
[l10n][Flame][2.1&2.2][Notifications]Trun on airplane mode, there is a prompt message for Usage. The " Please turn off wifi airplane mode to enable Usages" is truncated.
-------------------------------------------------------------
This issue exist in Serbian Cyrillic,Serbian Latin,Greek,Portuguese Brazil
This issue NOT exist in Spanish,Russian,Bengali from India,Polish,Basque,Portuguese Portugal
------------------------------------------------------------
Attachment:Serbian_Latin _Airplane.png   
                   Serbian_Cyrillic_airplane.png  
                   Serbian_Latin_airplane.png 
                   Greek_airplane.png 
                   Portuguese_Brazil_airplane.png

[2.Testing Steps]: 
Precondition:Set system language to Serbian Latin (This issue exist in Serbian Cyrillic,Serbian Latin,Greek,Portuguese Brazil)
1.Drag down notification bar
2.Tap Airplane icon to enable Airplane mode

[3.Expected Result]: 
2.The " Please turn off wifi airplane mode to enable Usages" should not be truncated.

[4.Actual Result]: 
2.The " Please turn off wifi airplane mode to enable Usages" is truncated.

[5.Reproduction build]: 
Flame 2.2 user:  Affected
Build ID               20150429002501
Gaia Revision          1b7aa7e60788668ed09abf76022dfa231dbe88d4
Gaia Date              2015-04-28 19:36:06
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/d38ff4717f39
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150429.040640
Firmware Date          Wed Apr 29 04:06:52 EDT 2015
Bootloader             L1TC000118D0

Flame 2.1 user:     Affected
Build ID               20150429001202
Gaia Revision          9fda4aec7f9495a27a335ccaf3b1a4dc9c4c6db0
Gaia Date              2015-04-28 19:33:50
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/38ab00c01159
Gecko Version          34.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150429.034244
Firmware Date          Wed Apr 29 03:42:55 EDT 2015
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test
(Reporter)

Comment 1

2 years ago
Created attachment 8599795 [details]
Geek_aiplane.png
(Reporter)

Comment 2

2 years ago
Created attachment 8599796 [details]
Portuguese_Brazil_airplane.png
(Reporter)

Comment 3

2 years ago
Created attachment 8599797 [details]
Serbian_Cyrillic_airplane.png
(Reporter)

Comment 4

2 years ago
Created attachment 8599798 [details]
Serbian_Latin _Airplane.png
(Reporter)

Updated

2 years ago
status-b2g-v2.1: --- → affected
status-b2g-v2.2: --- → affected
(Reporter)

Updated

2 years ago
Whiteboard: LocRun2.2, MGSEI-l10n-1F-Serbian Latin → LocRun2.2, MGSEI-l10n-1F
Fixed for Greek l10n:
https://hg.mozilla.org/gaia-l10n/el/rev/6fdda4274628
Why are you attaching pt-BR, sr, sr-Latn to a bug filed in el? The first 3 locales will never receive any notification of this error, it doesn't make any sense.

The only locales that you should group in one bug is Serbian, since it's the same team working on both of them.
Elie: for multiple same issues found for different locales, please file separate bugs and ask localizer if it's possible to shorten string. If it's not, then we might look into a dev fix. thanks
Flags: needinfo?(zikui.yang)
(Reporter)

Updated

2 years ago
Flags: needinfo?(zikui.yang)
Summary: [l10n][Notifications]The " Please turn off wifi airplane mode to enable Usages" is truncated. → [l10n][Notifications]Serbian Latin:The " Please turn off wifi airplane mode to enable Usages" is truncated.
Ok keeping this bug just for Serbian Latin, changing locale. Let's see if the localizer can shorten this string so that it fits. thanks
Assignee: pkst → nobody
Component: el / Greek → sr / Serbian
QA Contact: pkst
This was fixed in bug 1161459
Both Cyrl and Latin versions are fixed.
Closing this bug as resolved fix as per comment 9, and since we've changed it to reflect only Serbian.

Thanks all!
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
(Reporter)

Comment 11

2 years ago
This issue verified successfully on flame 2.1 &2.2
Device: Flame 2.1 user
Build ID               20150507161202
Gaia Revision          3e7bd686ecd852f4dfa4605b45f558e6bd34f02a
Gaia Date              2015-05-07 15:12:34
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/d85173eb5bf4
Gecko Version          34.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150507.194327
Firmware Date          Thu May  7 19:43:37 EDT 2015
Bootloader             L1TC000118D0


Device: Flame 2.2 user
Build ID               20150507002500
Gaia Revision          83a63e0e6fcc22c6a74b06ef77b88d5049719cad
Gaia Date              2015-05-07 00:17:17
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/118ddfc76b60
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150507.041806
Firmware Date          Thu May  7 04:18:17 EDT 2015
Bootloader             L1TC000118D0
status-b2g-v2.1: affected → verified
status-b2g-v2.2: affected → verified
(Reporter)

Updated

2 years ago
Status: RESOLVED → VERIFIED
QA Whiteboard: [MGSEI-l10n-1F]
Whiteboard: LocRun2.2, MGSEI-l10n-1F → LocRun2.2,
You need to log in before you can comment on or make changes to this bug.