editBookmarkOverlay.js throws an error in the Browser Console when adding a tag to a bookmark

VERIFIED FIXED in Firefox 40

Status

()

Firefox
Bookmarks & History
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: avaida, Assigned: mak)

Tracking

({regression})

40 Branch
Firefox 40
regression
Points:
2
Bug Flags:
firefox-backlog +

Firefox Tracking Flags

(firefox39 unaffected, firefox40 verified)

Details

Attachments

(1 attachment)

Reproducible on:
Nightly 40.0a1 (2015-04-30)

Affected platforms:
Windows 8.1 (x64), Ubuntu 14.04 (x64), Mac OS X 10.9.5

Steps to reproduce:
1. Launch Firefox.
2. Open a page that is NOT bookmarked.
3. Bookmark the page → add a tag, e.g. "test".

Expected result:
The tag is successfully added, without causing any errors.

Actual result:
The tag is added, but editBookmarkOverlay.js throws the following error in the Browser Console:
(a) without e10s:
> this._paneInfo is null editBookmarkOverlay.js:472:0
(b) with e10s:
> [Exception... "Illegal value'Illegal value' when calling method:
> [nsITaggingService::getTagsForURI]"  nsresult: "0x80070057 
> (NS_ERROR_ILLEGAL_VALUE)"  location: "JS frame :: 
> chrome://browser/content/places/editBookmarkOverlay.js :: 
> gEditItemOverlay._updateTags< :: line 474"  
> data: no] Promise-backend.js:870:0

Notes:
- This issue is NOT reproducible with Aurora 39.0a2 (2015-04-30) so it might be a recent regression.
(Assignee)

Updated

3 years ago
Blocks: 951651
Regression range
================
* Last good revision: 2f2888ca42c2
* First bad revision: 2a1ddf08a4b4
* Pushlog: https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=2f2888ca42c2&tochange=2a1ddf08a4b4
* Potential regressor: https://hg.mozilla.org/integration/mozilla-inbound/rev/d84b62b367b4 — Asaf Romano — Bug 951651 - Make bookmarkProperties, Star UI and Library info pane work with PlacesTransactions. r=mak
(Assignee)

Updated

3 years ago
Points: --- → 3
Flags: qe-verify+
Flags: firefox-backlog+
(Assignee)

Comment 2

3 years ago
By the time the code runs the pane has been closed already. The first error is harmless and we could start seeing more like this moving things to async since we can't predict timing the paneInfo goes away.

The difference with e10s is timing, in that case _paneInfo is still alive (maybe closing the panel is slower)... but at that point this._uri is a typo and thus invalid. This causes the NS_ERROR_ILLEGAL_VALUE error.
(Assignee)

Updated

3 years ago
Assignee: nobody → mak77
Status: NEW → ASSIGNED
Points: 3 → 2
(Assignee)

Comment 3

3 years ago
Created attachment 8600058 [details] [diff] [review]
patch v1
Attachment #8600058 - Flags: review?(mano)

Updated

3 years ago
Iteration: --- → 40.3 - 11 May
(Assignee)

Updated

3 years ago
Attachment #8600058 - Flags: review?(ttaubert)
Attachment #8600058 - Flags: review?(ttaubert) → review+
(Assignee)

Updated

3 years ago
Attachment #8600058 - Flags: review?(mano)
https://hg.mozilla.org/mozilla-central/rev/97ba42d0b930
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
status-firefox40: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 40
Status: RESOLVED → VERIFIED
status-firefox40: fixed → verified
Verified fixed on Windows 7 64bit, Mac OSX 10.9.5 and Ubuntu 13.10 32bit using latest Aurora 40.0a2 (buildID: 20150526004004).
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.