mathml msqrt doesn't render correctly in Win32

RESOLVED WORKSFORME

Status

()

Core
MathML
--
major
RESOLVED WORKSFORME
17 years ago
17 years ago

People

(Reporter: Jonathan Manning, Assigned: rbs)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(3 attachments)

(Reporter)

Description

17 years ago
msqrt - the square root function does not render correctly on Windows 2000
(possibily other Win32 platforms also)

It appears as a solid black box, and pushes away other elements instead of
bringing them under the sqrt.
mozilla.org's own torture test #13 (url above) reveals this error.

I am attaching screen shots. I will also try to create a testcase with the
minimum markup needed to reproduce.

I'm using Build ID: 2001112310 on Windows 2000.
(Reporter)

Comment 1

17 years ago
Created attachment 62205 [details]
Screenshot of mozilla.org testcase 13
(Reporter)

Comment 2

17 years ago
Created attachment 62223 [details]
Screenshot with Bakoma fonts - still wrong... and with ????'s

OK, so I noticed the note on the fonts page
(http://www.mozilla.org/projects/mathml/fonts/) that says:
"If you see symbols (like the square-root symbol) that appear jagged, then you
are not using TeX fonts from the Bakoma collection."

However, I installed the BakoMa fonts, and rebooted, and got the second
screenshot - question marks. Even worse. The workaround did *not* fix the
problem - perhaps it's for a different issue.
(Assignee)

Comment 3

17 years ago
Created attachment 62249 [details]
Works for me with the latest build
(Assignee)

Comment 4

17 years ago
I am resolving the bug as WORKSFORME although it could also be marked as a 
duplicate of one the other bugs about msqrt. This behavior typically means that 
the fonts are not installed properly. Are you using ATM (Adobe Type Manager) or 
smothing?
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
Summary: mathml msqrt doesn't render correctly in Win32 → mathml msqrt doesn't render correctly in Win32
You need to log in before you can comment on or make changes to this bug.