Closed Bug 1160171 Opened 5 years ago Closed 5 years ago

Web Components Spark: Buttons have an unrefined press state

Categories

(Firefox OS Graveyard :: Gaia::Components, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: padamczyk, Assigned: gasolin)

References

Details

(Keywords: polish)

Attachments

(2 files)

Attached image 2015-04-30-10-26-05.png
Please refer the web components repo created by Wilson viewed in Nightly: http://gaia-components.github.io/gaia-components/

When a button is pressed, you can see the bounding rectangle and they often have an aliased outline. See screenshot for the buttons I am referring to.
Component: Gaia::System → Gaia::Components
Blocks: 1160032
Comment on attachment 8601346 [details] [review]
pull request redirect to github

Though it's not a direct fix with press-rectangle issue, but after applying this PR (mainly lint and dependency package update), the press-rectangle issue is gone.

Set harly & jenny to UI review for gaia-button and see if we can pump it to `can Use` state in https://wiki.mozilla.org/Gaia/Shared/Components
Attachment #8601346 - Flags: ui-review?(jelee)
Attachment #8601346 - Flags: ui-review?(hhsu)
Attachment #8601346 - Flags: review?(wilsonpage)
Duplicate of this bug: 1160937
Comment on attachment 8601346 [details] [review]
pull request redirect to github

LGTM, thanks Fred :)
Attachment #8601346 - Flags: ui-review?(jelee)
Attachment #8601346 - Flags: ui-review?(hhsu)
Attachment #8601346 - Flags: ui-review+
Attachment #8601346 - Flags: review?(wilsonpage) → review+
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Assignee: nobody → gasolin
You need to log in before you can comment on or make changes to this bug.