Closed Bug 1160598 Opened 6 years ago Closed 6 years ago

url() in concatenated CSS files are incorrect when using Multiple Bugzilla databases with a single installation

Categories

(Bugzilla :: Bugzilla-General, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
Bugzilla 5.0

People

(Reporter: matthias-ludwig, Assigned: LpSolit)

References

Details

(Keywords: regression)

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; Trident/7.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; .NET4.0C; .NET4.0E; MDDRJS; rv:11.0) like Gecko

Steps to reproduce:

Update an existing bugzilla Installation from 4.4.9 to 5.0rc3

Installation uses the "Multiple Bugzilla databases with a single installation" feature
https://www.bugzilla.org/docs/4.4/en/html/multiple-bz-dbs.html



Actual results:

Images on start-page missing (/file-a-bug.png, etc.)
Calendar-symbol in search-view is missing

Images are referenced in css wich is loaded by the css download:
/data/<Project>/assets/d08a1840201cf4cdf63b858739ec25c9.css?1430496621

with <Project> as id of the instance


Content of the resulting css
../../skins/standard/index/file-a-bug.png

relative URLs in css are relative to the css-download and results in a wrong Location:

/data/skins/standard/index/file-a-bug.png






Expected results:

the algorithm for evaluating the URLs should consider that the "assets" Folder is one Level deeper for installations with "Multiple Bugzilla Databases"

it should result in:
/skins/standard/index/file-a-bug.png
Sounds like regression from the CSS minimization bug.
Depends on: 977969
Flags: blocking5.0?
Keywords: regression
Target Milestone: --- → Bugzilla 5.0
Flags: blocking5.0? → blocking5.0+
Attached patch patch, v1Splinter Review
Attachment #8600506 - Flags: review?(glob)
I can reproduce the issue. My patch fixes the problem.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: incorrect URLs when using Multiple Bugzilla databases with a single installation → url() in concatenated CSS files are incorrect when using Multiple Bugzilla databases with a single installation
Comment on attachment 8600506 [details] [diff] [review]
patch, v1

Review of attachment 8600506 [details] [diff] [review]:
-----------------------------------------------------------------

r=glob
Attachment #8600506 - Flags: review?(glob) → review+
Flags: approval5.0+
Flags: approval+
Assignee: general → LpSolit
Status: NEW → ASSIGNED
To ssh://gitolite3@git.mozilla.org/bugzilla/bugzilla.git
   cccc252..14bca7f  master -> master

To ssh://gitolite3@git.mozilla.org/bugzilla/bugzilla.git
   4c81579..3eb8ccc  5.0 -> 5.0
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Duplicate of this bug: 1170036
You need to log in before you can comment on or make changes to this bug.