Closed Bug 1160671 Opened 7 years ago Closed 7 years ago

[Flame] Unable to turn on NFC

Categories

(Firefox OS Graveyard :: NFC, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:2.0+, b2g-v2.0 verified, b2g-v2.1 verified, b2g-v2.2 verified, b2g-master unaffected)

VERIFIED FIXED
blocking-b2g 2.0+
Tracking Status
b2g-v2.0 --- verified
b2g-v2.1 --- verified
b2g-v2.2 --- verified
b2g-master --- unaffected

People

(Reporter: pcheng, Unassigned)

Details

(Keywords: regression, Whiteboard: [3.0-Daily-Testing])

Attachments

(2 files)

Attached file logcat of issue
Description:
The NFC toggle can not be toggled on in Settings. The toggle animates halfway showing white-blue switch instead of blue switch (on). Once it is in this state it cannot be toggled anymore.

STR:
1) Go to Settings and tap on NFC toggle

Expected: The toggle switch animates all the way, the switch color going from gray to blue. NFC can be toggled on.

Actual: The toggle switch animates halfway, color going from gay to white-blue. NFC cannot be toggled on.

Repro frequency: 5/5

Device: Flame 2.2
BuildID: 20150501002503
Gaia: 209bf4d6fcb16ea6834b8bd86976c012e5914fe6
Gecko: 79e7065ceefa
Gonk: a9f3f8fb8b0844724de32426b7bcc4e6dc4fa2ed
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
3.0 and 2.1 are unaffected. NFC can be turned on.

Device: Flame 2.1 (full flashed 319MB KK)
BuildID: 20150501001200
Gaia: b4a03b7ee61de5a479b3cf0916f47e91a43b0f50
Gecko: e488b1448f95
Gonk: a9f3f8fb8b0844724de32426b7bcc4e6dc4fa2ed
Version: 34.0 (2.1) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Device: Flame 3.0 Master (full flashed 319MB KK)
BuildID: 20150501010203
Gaia: 759a1f935a6a81c32ad66e39a6353b334dfa4f91
Gecko: 7723b15ea695
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 40.0a1 (3.0 Master)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: regression
Whiteboard: [3.0-Daily-Testing]
Major deature is broken so nominating 2.2?
blocking-b2g: --- → 2.2?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
*feature
QA Contact: pcheng
This issue is caused by a Gonk change within b2g37 (v2.2) branch.

Last Working
Device: Flame
BuildID: 20150429203150
Gaia: aa1da5036f9425c25d515d14243d3473bfefb4fd
Gecko: 38b2838d43e1
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

First Broken
Device: Flame
BuildID: 20150430145915
Gaia: c077b9d502205cdb72ef9a4f425259dc2f990ff8
Gecko: e4f5f8dc5b53
Gonk: a9f3f8fb8b0844724de32426b7bcc4e6dc4fa2ed
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Gaia and Gecko swaps were done on top of Gonk.
The broken Gonk reproduces the issue regardless of which Gaia/Gecko are flashed on top.
The working Gonk does NOT reproduce the issue regardless of which Gaia/Gecko are flashed on top.

Confirmed working Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Confirmed broken Gonk: a9f3f8fb8b0844724de32426b7bcc4e6dc4fa2ed
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Alison, can you take a look at this please?
Flags: needinfo?(ashiue)
Flags: needinfo?(nhirata.bugzilla)
This bug seems related to fixing in bug 1155035, in that bug device-flame repository is set to branch 'kitkat', but originally it is set to revision 'ebad7da532429a6f5efadc00bf6ad8a41288a429' because of bug 1146741.
set device-flame to 'kitkat' for branches are not master will cause NFC not work.

I think the correct solution should be using branch.

Thomas,Eric do you have any idea about this bug ?
Flags: needinfo?(tzimmermann)
Flags: needinfo?(etsai)
Flags: needinfo?(ashiue)
[Blocking Requested - why for this release]:
Basic function does not work.
blocking-b2g: 2.2? → 2.0?
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][COM=NFC]
Flags: needinfo?(kli)
I think we can create a new branch for device-flame and apply the patch of bug 1155035 on the top of 'ebad7da532429a6f5efadc00bf6ad8a41288a429'. And then Update flame-kk.xml manifest in v2.0/v2.1/v2.2 branch accordingly.
Flags: needinfo?(kli)
Bug 1155035, effectively reverted the fix for bug 1146741 by setting this repository branch to 'kitkat'.

We discussed the underlying problem in bug 1146741 comment 15 and below. In short, we cannot use a single device branch for all versions of Android. Instead we'll need to handle each Android version in a new repository (i.e., device-flame-kk, device-flame-l, and so on).
Flags: needinfo?(tzimmermann)
Yeah, I think comment 9 has the near-term solution.
One other alternative solution could be, we need to back port bug 1109592 to v2.0/v2.1/v2.2. But IMO, i don't think this is a better solution as there are many changes in gecko.
I agree. Porting bug 1109592 to v2.2 doesn't sound appealing to me because it's too much code. And that would still not fix the issue in v2.1.

The real problem is that v2.2 uses a branch that only works for Kitkat's master version. That's what needs to be fixed. I think any name for the new branch should be fine (e.g., v2.2-kitkat, katkat-v2.2, etc).
Hal,

just to make sure that a fix doesn't break the builds: Does the infrastructure at git.m.o depend on actual branch names?
Flags: needinfo?(hwine)
AIK, after the repo was mirrored, when there is new branch in the repo, it will also be mirrored. So add a new branch won't break the build.
Piwei, As bug 1155035 which caused the regression was updated, could you resolve this bug once you verified it is fixed? Thanks!
Flags: needinfo?(pcheng)
I'll verify it in the next nightly. Also changing title as it seems that this is no longer v2.2 only.
Summary: [Flame v2.2] Unable to turn on NFC → [Flame] Unable to turn on NFC
Clearing my NI.  Looks like this is going to be covered; we just need to make sure that the device-flame picks up the right versions in the manifests for the builds.
Flags: needinfo?(nhirata.bugzilla)
(In reply to Thomas Zimmermann [:tzimmermann] [:tdz] from comment #14)
> Hal,
> 
> just to make sure that a fix doesn't break the builds: Does the
> infrastructure at git.m.o depend on actual branch names?

The vcs-sync infrastructure does not depend on branch names for repositories we are just mirroring to git.mozilla.org. It will auto propagate.

What does matter is the branch referred to in the manifest. If the manifest change lands before the repo is updated, the build will break.
Flags: needinfo?(hwine)
Flags: needinfo?(etsai)
triage: breaking basic function.
blocking-b2g: 2.0? → 2.0+
This issue is verified fixed on Flame 2.2. NFC can be turned on successfully.

Device: Flame 2.2
BuildID: 20150505002501
Gaia: 772a9491909abd02dc67278dd453746e2dd358a8
Gecko: 2df83538ae20
Gonk: ab265fb203390c70b8f2a054f38cf4b2f2dad70a
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Device: Flame 2.1
BuildID: 20150505001204
Gaia: b4a03b7ee61de5a479b3cf0916f47e91a43b0f50
Gecko: 4493015380ab
Gonk: ab265fb203390c70b8f2a054f38cf4b2f2dad70a
Version: 34.0 (2.1) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Device: Flame 2.0
BuildID: 20150505000201
Gaia: 84898cadf28b1a1fcd03b726cff658de470282f0
Gecko: e67ed29e8ad0
Gonk: ab265fb203390c70b8f2a054f38cf4b2f2dad70a
Version: 32.0 (2.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
Status: NEW → RESOLVED
Closed: 7 years ago
QA Whiteboard: [QAnalyst-Triage+][COM=NFC] → [QAnalyst-Triage?][COM=NFC]
Flags: needinfo?(pcheng)
Resolution: --- → FIXED
Status: RESOLVED → VERIFIED
Flags: needinfo?(ktucker)
^ First sentence missed out two branches. It is verified fixed on 2.1 and 2.0 as well.
QA Whiteboard: [QAnalyst-Triage?][COM=NFC] → [QAnalyst-Triage+][COM=NFC]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.