Closed Bug 1160734 Opened 5 years ago Closed 5 years ago

Let about:downloads use the new in-content style-sheet

Categories

(Firefox :: Theme, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 40
Tracking Status
firefox40 --- fixed

People

(Reporter: Paenglab, Assigned: Paenglab)

References

Details

Attachments

(1 file, 2 obsolete files)

about:downloads should use the new in-content style-sheet to be able to remove the old inContentUI.css.
Blocks: 1160731
Attached patch Bug1160734.patch (obsolete) — Splinter Review
If the new add-on manager richlistitem styling is wanted, I think this should be done in a followup bug.
Assignee: nobody → richard.marti
Status: NEW → ASSIGNED
Attachment #8600597 - Flags: review?(mak77)
Comment on attachment 8600597 [details] [diff] [review]
Bug1160734.patch

Review of attachment 8600597 [details] [diff] [review]:
-----------------------------------------------------------------

::: browser/themes/shared/downloads/contentAreaDownloadsView.css
@@ +20,5 @@
> +}
> +
> +.downloadButton > .button-box {
> +  padding-right: 3px !important;
> +  padding-left: 3px !important;

I honestly think it looks better without these paddings. I know it's different than before, but it's closer to the downloads panel, while it was not before.

@@ +21,5 @@
> +
> +.downloadButton > .button-box {
> +  padding-right: 3px !important;
> +  padding-left: 3px !important;
> +  padding-bottom: 1px;

padding: 0; looks like it's enough here
Attachment #8600597 - Flags: review?(mak77) → review+
Attached patch Bug1160734.patch (obsolete) — Splinter Review
Okay, changed to padding 0px. The !important is needed to override the common.css rule. I added a comment.

Carrying over the r+
Attachment #8600597 - Attachment is obsolete: true
Attachment #8602239 - Flags: review+
Keywords: checkin-needed
wait, I don't want to override the left/right padding with 0, I suggested padding: 0; just as a shortcut to padding-bottom: 0;
Why do you think we must override the side paddings?
Keywords: checkin-needed
(In reply to Marco Bonardo [::mak] from comment #4)
> Why do you think we must override the side paddings?

It was this:
(In reply to Marco Bonardo [::mak] from comment #2)
> Comment on attachment 8600597 [details] [diff] [review]
> I honestly think it looks better without these paddings. I know it's
> different than before, but it's closer to the downloads panel, while it was
> not before.

The downloads panel has 0px on all sides.

You want 10px on left/right (the in-content values) and 0px on top/bottom, correct?
Flags: needinfo?(mak77)
It looks good to me on Windows with just padding-bottom: 0px; and it looks visually closer to the downloads panel. I think we can keep the in-content values for left/right padding.
Flags: needinfo?(mak77)
Attached patch Bug1160734.patchSplinter Review
This time with padding-bottom: 0.

Carrying over r+
Attachment #8602239 - Attachment is obsolete: true
Attachment #8602588 - Flags: review+
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/3a906efc756d
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 40
Regressions: 1536402
Depends on: 1536402
No longer regressions: 1536402
You need to log in before you can comment on or make changes to this bug.