pdf.js text has lost subpixel-antialising on OS X

RESOLVED FIXED in Firefox 49

Status

()

Core
Graphics
RESOLVED FIXED
3 years ago
a year ago

People

(Reporter: mstange, Unassigned)

Tracking

({regression})

40 Branch
mozilla45
All
Mac OS X
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox49 fixed)

Details

(Whiteboard: [gfx-noted])

Attachments

(1 obsolete attachment)

(Reporter)

Description

3 years ago
I suppose this was caused by the switch to Skia in bug 932958, and by the fact that we don't tell Skia to use subpixel-AA during text rendering.
(Reporter)

Updated

3 years ago
OS: Unspecified → Mac OS X
Hardware: Unspecified → All
(Reporter)

Comment 1

3 years ago
Created attachment 8600953 [details] [diff] [review]
patch
Assignee: nobody → mstange
Status: NEW → ASSIGNED
Attachment #8600953 - Flags: review?(jmuizelaar)
(Reporter)

Comment 2

3 years ago
Comment on attachment 8600953 [details] [diff] [review]
patch

This makes text rendered into transparent parts of a canvas look broken.
Attachment #8600953 - Flags: review?(jmuizelaar)
(Reporter)

Updated

3 years ago
Depends on: 1161122
(Reporter)

Updated

3 years ago
Depends on: 1161147
(Reporter)

Comment 3

3 years ago
Comment on attachment 8600953 [details] [diff] [review]
patch

I put a patch that does this only for opaque canvases in bug 1161122. However, that doesn't fix pdf.js because the pdf.js canvas is not opaque. I filed bug 1161147 about that.
Attachment #8600953 - Attachment is obsolete: true
(Reporter)

Comment 4

3 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/4d1f80117dd4
https://hg.mozilla.org/mozilla-central/rev/4d1f80117dd4
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
status-firefox41: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla41
(Reporter)

Comment 6

3 years ago
Oops, I put the wrong bug number on that changeset. It actually only fixes bug 1161122, and pdf.js still doesn't get subpixel AA.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Reporter)

Updated

3 years ago
Assignee: mstange → nobody
Status: REOPENED → NEW
Target Milestone: mozilla41 → ---

Updated

2 years ago
Whiteboard: [gfx-noted]
Does this bug still reproduce?
status-firefox40: affected → ---
Flags: needinfo?(mstange)
Version: Trunk → 40 Branch
(Reporter)

Comment 8

a year ago
No, this was fixed by the combination of bug 1161122 and bug 1160789.
Status: NEW → RESOLVED
Last Resolved: 3 years agoa year ago
status-firefox41: fixed → affected
status-firefox49: --- → fixed
Flags: needinfo?(mstange)
Resolution: --- → FIXED
Target Milestone: --- → mozilla45
(In reply to Markus Stange [:mstange] from comment #8)
> No, this was fixed by the combination of bug 1161122 and bug 1160789.

Thanks!
status-firefox41: affected → ---
You need to log in before you can comment on or make changes to this bug.