Make e10s possible to be opted-in on Aurora and display popup asking users to try it

RESOLVED FIXED in Firefox 40

Status

()

defect
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: Felipe, Assigned: Felipe)

Tracking

unspecified
Firefox 40
Points:
1

Firefox Tracking Flags

(e10sm6+, firefox40 fixed)

Details

Attachments

(4 attachments, 1 obsolete attachment)

To-do:

- define E10S_TESTING_ONLY to aurora
- revert autostart=true to NIGHTLY only
- tweak e10s opt-in popup text
- discuss if a kill switch is necessary
Posted patch E10S_TESTING_ONLY for Aurora (obsolete) — Splinter Review
Attachment #8601489 - Flags: review?(mh+mozilla)
Iteration: --- → 40.3 - 11 May
Points: --- → 1
Flags: qe-verify+
Posted image Current wording.png
Blassey, this is the current message that is displayed, up to 5 times if the user chooses "Not now" (There's also the "No thanks" option). I imagine we want to change the text for Aurora.. Any thoughts? And anything you want to tweak about the behavior?
Attachment #8601576 - Flags: feedback?(blassey.bugs)
I think dcamp had some ideas about the wording, NI'ing him
Flags: needinfo?(dcamp)
Attachment #8601576 - Attachment description: Screen Shot 2015-05-05 at 1.30.53 PM.png → Current wording.png
Attachment #8601493 - Flags: review?(wmccloskey) → review+
I'd suggest:

a) Get rid of the e10s moniker - call it "Multi-process Firefox" or something.
b) I'd be more urgent, and make it clear that this is becoming real soon.

I'm no wordsmith, but I'd say something like:

"Multi-process is coming soon to Firefox.  You can start using it now to get early access to some of the benefits:

* Improved responsiveness
* Whatever other things

Multi-process can be enabled from the preferences window.
"

Out of curiosity, how long does the "not now" nag delay?
Flags: needinfo?(dcamp)
We could also say something about addon compatibility - "If you're an addon developer, now's a great time to prepare your addon for Multi-Process Firefox" - but I'd worry about the nag getting too wordy.
Comment on attachment 8601576 [details]
Current wording.png

Let's update the wording as Dave suggested. Also NI'ing Matej to see if he has any edits
Flags: needinfo?(matej)
Attachment #8601576 - Flags: feedback?(blassey.bugs)
I've been going in circles about whether it should be "Less crashing" or "Fewer crashes," but I think I'm fine either way. Otherwise, looks good. Thanks.
Flags: needinfo?(matej)
Comment on attachment 8601489 [details] [diff] [review]
E10S_TESTING_ONLY for Aurora

Review of attachment 8601489 [details] [diff] [review]:
-----------------------------------------------------------------

::: configure.in
@@ +3522,5 @@
>  dnl ========================================================
>  dnl Multiprocess Firefox Nightly Testing UI
>  dnl To be removed in Bug 1003313
>  dnl ========================================================
> +if test -n "$NIGHTLY_BUILD" || test -n "$AURORA_BUILD"; then

No need to add the AURORA_BUILD variable. You can just rely on RELEASE_BUILD not being set if you want something on aurora+nightly. (test -z "$RELEASE_BUILD")
Attachment #8601489 - Flags: review?(mh+mozilla) → feedback+
Attachment #8601489 - Attachment is obsolete: true
Attachment #8601828 - Flags: review?(mh+mozilla)
Comment on attachment 8601828 [details] [diff] [review]
E10S_TESTING_ONLY for Aurora

Review of attachment 8601828 [details] [diff] [review]:
-----------------------------------------------------------------

::: configure.in
@@ +3519,5 @@
>  AC_SUBST(RELEASE_BUILD)
>  
>  dnl ========================================================
>  dnl Multiprocess Firefox Nightly Testing UI
>  dnl To be removed in Bug 1003313

You may want to update this comment to say this is enabled on aurora and nightly.
Attachment #8601828 - Flags: review?(mh+mozilla) → review+
So taking from everyone's comments, I'll go with the following text if I don't hear objections:

"
Multi-process is coming soon to Firefox. You can start using it now to get early access to some of the benefits:

* Improved responsiveness
* Fewer crashes
"

I tried including the message to add-on developers but the popup felt too heavy, and it's something that non add-on developers users don't need to read, so I removed it.
Blassey, one last question: all of the strings related to e10s experimentation are currently hardcoded because non-english strings didn't have much value in Nightly and we didn't want to bother localizers with strings that will not make it to release.

This trade-off might be different for Aurora though. Do you want to keep them English only (and perhaps only display the popup to english users), or make them localizable? Talking about this with Mossop we figured we could make them localizable and add a Localization Note saying that won't ride the trains, so that the contributors can decide for themselves if it's worth spending their time on that or not.
Flags: needinfo?(blassey.bugs)
Since we're at least considering prompting for beta as well, let's go ahead and make them localizable and add a note saying this won't hit beta until at least 41
Flags: needinfo?(blassey.bugs)
Attachment #8602837 - Flags: review?(wmccloskey) → review+
https://hg.mozilla.org/mozilla-central/rev/31d0c2824009
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 40
I've tested on Windows 7 64bit, Ubuntu 12.04 and Mac OSX 10.9.5 using latest Aurora 41.0a2 (buildID: 20150712004007) and I have the following results:

- on Windows and Mac: when I opened Firefox with a clean profile, the e10s pop-up is displayed for 1 second and then disappears (and also disappears the notification icon from Navigation Bar) -> I restarted Firefox and the notification icon is correctly displayed now under Navigation Bar.
- on Ubuntu: the same behaviour, but here, after restart, the notification icon is not displayed anymore.

Any thoughts about that?
Flags: needinfo?(mh+mozilla)
Flags: needinfo?(felipc)
I only reviewed build changes, I have no idea.
Flags: needinfo?(mh+mozilla)
Since we've enabled e10s by default in DevEdition 42, it seems like there's nothing more to do here.
Flags: qe-verify+
(In reply to Camelia Badau, QA [:cbadau] from comment #18)
> I've tested on Windows 7 64bit, Ubuntu 12.04 and Mac OSX 10.9.5 using latest
> Aurora 41.0a2 (buildID: 20150712004007) and I have the following results:
> 
> - on Windows and Mac: when I opened Firefox with a clean profile, the e10s
> pop-up is displayed for 1 second and then disappears (and also disappears
> the notification icon from Navigation Bar) -> I restarted Firefox and the
> notification icon is correctly displayed now under Navigation Bar.
> - on Ubuntu: the same behaviour, but here, after restart, the notification
> icon is not displayed anymore.
> 
> Any thoughts about that?

I think this was caused by the "Make FF your default browser" alert, which would only hope for brand new profiles. And since in Aurora starting from 42 we've enabled e10s by default too, I believe we don't need to worry about this.
Flags: needinfo?(felipc)
You need to log in before you can comment on or make changes to this bug.