[l10n][Wifi]Polish:"Automatic Wi-Fi setup" string is truncated.

VERIFIED FIXED

Status

VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: huayu.li, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.1 wontfix, b2g-v2.2 unaffected)

Details

(Whiteboard: LocRun2.2)

Attachments

(4 attachments)

(Reporter)

Description

3 years ago
Created attachment 8601379 [details]
Polish_Automatic Wi-Fi setup.png

[1.Description]:
[l10n][v2.1&v2.2][Wifi]Polish:When we select My PIN connection in WIFI, cancel WPS connecting in wifi list page, "Automatic Wi-Fi setup" string is displayed truncated.

See attachment:Polish_Automatic Wi-Fi setup.png

[2.Testing Steps]: 
1. Updated Flame to BuildID: 20150504002502
2. Choose Polish as the language during set-up.
3. Navigate to Settings app
4. Tap on Wi-Fi
5. Tap on Connect with WPS 
6. Tap on "My PIN connection" 
7. Tap OK.
8. In the settings prompt page, tap "OK".
9.Tap "Cancel WPS".

[3.Expected Result]: 
9."Automatic Wi-Fi setup" string is not truncated.

[4.Actual Result]: 
9.Waiting for about 2 secs, "Automatic Wi-Fi setup" string is displayed and it is truncated.

[5.Reproduction build]: Device: 
Flame 2.1 user [Affected]
Build ID               20150504002502
Gaia Revision          b4a03b7ee61de5a479b3cf0916f47e91a43b0f50
Gaia Date              2015-04-30 21:31:55
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/03bfe12e50d0
Gecko Version          34.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150504.040736
Firmware Date          Mon May  4 04:07:47 EDT 2015
Bootloader             L1TC000118D0

Device: Flame2.2 user [Affected]
Build ID               20150504002502
Gaia Revision          8d14361337e608c8cdf165ea5034db5eda23b618
Gaia Date              2015-05-01 18:23:46
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/cb7cb6597c91
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150504.041541
Firmware Date          Mon May  4 04:15:53 EDT 2015
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test
This string shouldn't appear (jump to) as main label in a first line, only as status/description in second like in the initial state.
Component: pl / Polish → Gaia::Settings
Product: Mozilla Localizations → Firefox OS
(Reporter)

Comment 2

3 years ago
Hi Delphine, could you help to check this issue? It also exist on other language, but some of them has been fixed.
Flags: needinfo?(lebedel.delphine)
(Reporter)

Comment 3

3 years ago
This issue has been verfied as pass on flame 2.2, but it is failed vrified on flame2.1
Device: Flame 2.1 user
Build ID               20150517001201
Gaia Revision          c80865cb0bf73f1b97defbc646083b404feb3ac4
Gaia Date              2015-05-12 06:26:43
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/86182f8fc3f1
Gecko Version          34.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150517.040359
Firmware Date          Sun May 17 04:04:09 EDT 2015
Bootloader             L1TC000118D0


Device: Flame 2.2 user
Build ID               20150517002501
Gaia Revision          b388a235e89dab76c24323767cd87ebd7c4c8b17
Gaia Date              2015-05-15 16:08:41
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/54ae7c7182bc
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150517.041351
Firmware Date          Sun May 17 04:14:01 EDT 2015
Bootloader             L1TC000118D0
status-b2g-v2.2: affected → verified
(Reporter)

Comment 4

3 years ago
Created attachment 8606938 [details]
verify1_fail_flame2.1.png
(Reporter)

Comment 5

3 years ago
Created attachment 8606964 [details]
verify1_pass_flame2.2.png
(Reporter)

Updated

3 years ago
status-b2g-v2.2: verified → unaffected
This barely fit on 2.1 but given the we're way past that cycle, I don't think we're going to get a dev fix for this. 
Stefan: for 2.1, do you think you could shorten the string to "Automatic Setup"? Since we're already under the WIFI page, there's enough context there to understand what this string means.
If you don't want to do that, let's mark this bug as wontfix for 2.1. thanks!
Flags: needinfo?(lebedel.delphine) → needinfo?(splewako)
Created attachment 8607625 [details]
master/trunk

This is how it looks on master but on 2.x it shouldn't be much different.

All other places where gaia devs decided to creatively reuse the string (wpsDescription2) are the problem (and not the string length).
Flags: needinfo?(splewako)
Thanks for the info Stefan!
Status: NEW → RESOLVED
Last Resolved: 3 years ago
status-b2g-v2.1: affected → wontfix
Resolution: --- → FIXED
(Reporter)

Comment 9

3 years ago
Per comment3 and comment8, change the status as VERIFIED FIX.
Status: RESOLVED → VERIFIED
QA Whiteboard: [MGSEI-Triage+][MGSEI-l10n-1F]
Whiteboard: LocRun2.2,MGSEI-l10n-1F → LocRun2.2
You need to log in before you can comment on or make changes to this bug.