Closed Bug 116157 Opened 23 years ago Closed 23 years ago

Add button in bookmarks sidebar panel should prefill values

Categories

(SeaMonkey :: Bookmarks & History, defect, P3)

Tracking

(Not tracked)

VERIFIED FIXED
mozilla1.0

People

(Reporter: pbergsagel, Assigned: bugzilla)

References

()

Details

(Keywords: regression, Whiteboard: [adt3])

Attachments

(1 file, 1 obsolete file)

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC; en-US; rv:0.9.6+) Gecko/20011219
BuildID:    2001121908

I know the bookmarks have recently undergone a re-write. Lately it has become
much harder to manage bookmarks. In order to add a new bookmark one now has to
select the folder in the sidebar first (so Mozilla will know were to file the
bookmark) select the url at the top of the page and copy it to the clipboard.
Now you can select "add" in the bookmarks tab of the sidebar and copy the url to
the pop-up dialogue box and supply a bookmark name. The item "Manage" has lost
almost all of its functionallity and is now mostly useless.

It liked the previous method for bookmark management. Previously to manage a
bookmark all the user had to do was to click on "Add" in the bookmark's side bar
and a dialogue box would pop up with the url filled in and a name for the
bookmark provided by the webmnaster of the saite being bookmarked. I you wanted
to you could edit these two values. When you clicked on "ok" another menu poped
up asking you which bookmark folder to file the bookmark in.

Can we begin a discussion about a better method for handling bookmarks then the
one used in the nightlies (12/17/01). The present method IMHO lacks a lot of
useful functionality and is only marginally beter than NS 4.7 which was really
terrible. How should Mozilla manage/file the bookmarks?

(Hopefully the loss of functionality of bookmark management is due to the recent
bookmark code re-write and this loss of functionality was not added on purpose.)

Reproducible: Always
Steps to Reproduce:
1.n/a
2.
3.

Actual Results:  n/a

Expected Results:  n/a

I am filing this bug to hopefully bgin a dialogue about how Mozilla might handle
bookmark management.
Adding the keyword "regression".
Keywords: regression
Attached patch patch (obsolete) — Splinter Review
to me.
Assignee: pchen → blakeross
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: A regression iin the management of bookmarks. → Add button in bookmarks sidebar panel should prefill values
Blocks: 114455
No longer blocks: 114455
-> ben
Assignee: blaker → ben
Status: NEW → ASSIGNED
Priority: -- → P3
Target Milestone: --- → mozilla1.1
Keywords: nsbeta1
nsbeta1+ per ADT/Nav triage. This also occurs on Windows, so changing to ALL
Platforms.

IS the current patch from Blake, still good to go?
OS: Mac System 8.6 → All
Hardware: Macintosh → All
Target Milestone: mozilla1.1 → mozilla1.0
Keywords: nsbeta1nsbeta1+
I'm also unhappy with the current situation.  A couple comments...
Adding a bookmark, because it's done so frequently, should be
quick and easy.  Generally, I find myself wanting to
  - Add a bookmark, placed according to the selected entry in
    the sidebar list (i.e., if it is a folder, place it in the
    selected folder; if it is a bookmark, place it just after
    the selection, in the folder to which the selection belongs)
or
  - Add a folder (again according to the selected entry), so I
    can then add a bookmark.
It would be nice if the sidebar buttons accomodated both these
actions with a minimum of fuss.

For further streamlining, there could be a single-click version of
the "Add" action (activated, say, by shift-clicking "Add"?)
that doesn't even open a pop-up, but just uses the current page's
title and URL.
*** Bug 116344 has been marked as a duplicate of this bug. ***
Whiteboard: [adt3]
Attachment #62310 - Attachment is obsolete: true
-> me
Assignee: ben → blaker
Status: ASSIGNED → NEW
Comment on attachment 74688 [details] [diff] [review]
patch that restores old behavior

r=hewitt
Attachment #74688 - Flags: review+
Comment on attachment 74688 [details] [diff] [review]
patch that restores old behavior

a=scc
Attachment #74688 - Flags: approval+
fixed.
Status: NEW → RESOLVED
Closed: 23 years ago
Resolution: --- → FIXED
VERIFIED Fixed 20020326 build
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: