Closed Bug 1161706 Opened 5 years ago Closed 2 years ago

Animation paused repeatedly by garbage collection

Categories

(Core :: JavaScript: GC, defect)

46 Branch
x86
macOS
defect
Not set

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: tobi, Unassigned)

References

Details

Attachments

(2 files)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:37.0) Gecko/20100101 Firefox/37.0
Build ID: 20150415140819

Steps to reproduce:

1) Opened http://www.goodboydigital.com/pixijs/bunnymark/ , clicked perhaps once on the white box (WegGL canvas).

2) Opened http://tobireif.com/non_site_stuff/unfinished_pixijs_demo_copy_for_bug_report/ .



Actual results:

In both cases I noticed severe jank/pauses caused by garbage collection.

Also see the attached image "pixijs_bunnymark_firefox_fps_gc_bad_ani_perf.png".


Expected results:

Smooth animation throughout.

Additional info:

Difficult to reproduce, seems to work after a browser/OS restart.

Regarding
http://tobireif.com/non_site_stuff/unfinished_pixijs_demo_copy_for_bug_report/
I can say that at one point while there were repeated & severe pauses in Firefox, there was no issue in Chrome. Now after a browser/OS restart, the animation is smooth in both browsers.

I hope you can reproduce and fix the issue.
I managed to reproduce the issue. I opened
http://www.tobireif.com/non_site_stuff/unfinished_pixijs_demo_copy_for_bug_report/
in several tabs (also in Chrome), then closed (Chrome and) all but one Firefox tab. (Perhaps opening the page in Chrome isn't required for reproducing the issue.)
There was a severe pause in the animation.
Please see the attachment "screenshot_firefox_fps_gc.png".
Hi, 

I have tested this on Mac OS X 10.9 and 10.10 with the latest Nightly 46.0a1 and I can't reproduce the problem. 

Please download the Firefox Nightly from here: https://nightly.mozilla.org/ and retest the problem.

If you still have the issue please create a new profile, you have the steps here:https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles?redirectlocale=en-US&redirectslug=Managing-profiles#w_starting-the-profile-manager

Please test if the issue can be reproduced in the safe mode of Firefox: https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode
Flags: needinfo?(tobi)
I just managed to reproduce the issue, again. (in the latest Nightly, fresh profile)

Please try this:

Open
http://www.tobireif.com/non_site_stuff/unfinished_pixijs_demo_copy_for_bug_report/
in 5 tabs in Chrome, and in 5 tabs in the latest Firefox Nightly.

Close all tabs in Chrome, close Chrome.
In Nightly close all tabs except one. Watch the animation right away, for 20 seconds. I observed a short pause/jank/hiccup in the animation.

(Perhaps opening the page in Chrome isn't required for reproducing the issue, but that's how I did it.)
Flags: needinfo?(tobi)
I also tried to test it in Safe Mode (using Nightly):

The page stays blank (white) without any error messages in the console.
If anyone considers that the component is not the right one, please change it to a more appropriate one.
Component: Untriaged → Graphics
OS: Unspecified → Mac OS X
Product: Firefox → Core
Hardware: Unspecified → x86
Version: 37 Branch → 46 Branch
This seems like a problem of GC, not canvas.
Component: Graphics → JavaScript: GC
It looks similar to bug 1160228.
See Also: → 1160228
Do you still see this when using a current version?
Flags: needinfo?(tobi)
The latest/finished version of my demo (old URL http://tobireif.com/non_site_stuff/unfinished_pixijs_demo_copy_for_bug_report/ )  is at https://tobireif.com/demos/swirls/ .

When I follow my steps using Firefox 58.0.2 (64-bit) on the latest Mac OS and the above new URL, the issue seems resolved.

(Nightly doesn't not let me load the same URL in multiple tabs - is that intended?)
Flags: needinfo?(tobi)
Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.