[App/Datastore Permissions]There is no camera choice in the "Website Permission" view.

RESOLVED DUPLICATE of bug 1162720

Status

RESOLVED DUPLICATE of bug 1162720
3 years ago
2 years ago

People

(Reporter: lulu.tian, Unassigned)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.5?, b2g-v2.2 unaffected, b2g-master verified)

Details

(Whiteboard: [3.0-nexus-5-l])

Attachments

(8 attachments)

(Reporter)

Description

3 years ago
Created attachment 8601848 [details]
logcat_0932.txt

[1.Description]:
According to comment 28 in bug 1154209, this bug is filed.
[Flame v3.0][Nexus 5 3.0][App/Datastore Permissions]There is no camera choice in the "Website Permission" view even though you've already launched camera.
Found time:09:32
See attachment:logcat_0932.txt and video.mp4

[2.Testing Steps]: 
1. Flash or reset the phone to bring up the FTE and finish the FTE to view the homescreen .
2. Tap Camera from the home screen and wait for the Camera permission view to pop up. 
3. Back home and open the Browser app. 
4. Navigate to webcamtoy.com. 
5. Tap on "Ready? Smile!" and then tap on "Use my camera!" .

[3.Expected Result]: 
5. Everything in "Website Permission" view should be shown correctly.

[4.Actual Result]: 
5. There is no camera choice in "Website Permission" view.

[5.Reproduction build]: 
Device: Flame 2.2 (unaffected)
Build ID               20150505002501
Gaia Revision          772a9491909abd02dc67278dd453746e2dd358a8
Gaia Date              2015-05-05 02:02:24
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/2df83538ae20
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150505.041743
Firmware Date          Tue May  5 04:18:00 EDT 2015
Bootloader             L1TC000118D0

Device: Flame 3.0 (affected)
Build ID               20150505010204
Gaia Revision          70077825aab2c7a79611befb40a5fe7e610d5443
Gaia Date              2015-05-04 18:09:33
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/102d0e9aa9e1
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150505.043622
Firmware Date          Tue May  5 04:36:34 EDT 2015
Bootloader             L1TC000118D0

Device: Nexus 5 2.2 (unaffected)
Build ID               20150505002501

Gaia Revision          772a9491909abd02dc67278dd453746e2dd358a8

Gaia Date              2015-05-05 02:02:24

Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/2df83538ae20

Gecko Version          37.0

Device Name            hammerhead

Firmware(Release)      5.1

Firmware(Incremental)  eng.cltbld.20150505.041235

Firmware Date          Tue May  5 04:12:53 EDT 2015

Bootloader             HHZ12f

Device: Nexus 5 3.0 (affected)
Build ID               20150505160203
Gaia Revision          42dc5f02a9df006b129824cd9bffa93cab937ab2
Gaia Date              2015-05-05 11:06:17
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/5907a8eca521
Gecko Version          40.0a1
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150505.192812
Firmware Date          Tue May  5 19:28:29 EDT 2015
Bootloader             HHZ12f

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test
(Reporter)

Comment 1

3 years ago
Created attachment 8601850 [details]
video.mp4
(Reporter)

Updated

3 years ago
status-b2g-v2.2: --- → unaffected
status-b2g-master: --- → affected
Component: Gaia::System → Gaia::Browser
See Also: → bug 1154209
Created attachment 8601863 [details]
v22vsmaster.jpg
[Blocking Requested - why for this release]: broken functionality
blocking-b2g: --- → 3.0?
Flags: needinfo?(hochang)

Comment 4

3 years ago
carry bug 1154209 comment 27 :

```
I can reproduce in master (without change to RTL)
with webcamtoy.com, I saw no camera choice as well.

with some error log:
W/GeckoConsole(17698): [JavaScript Warning: "SyntaxError: unreachable code after return statement" {file: "resource://gre/modules/MobileIdentityManager.jsm" line: 237 column: 4 source: "    return null;


But with general test with ui test app > API > getUserMedia > Video
The camera choice shows correctly.
```

And once I confirm the camera sharing, the flame is crashed.

webcamtoy.com 's source is minified, so it might be more efficient to see what's passed to gecko and what option cause the crash.
Keywords: regressionwindow-wanted
QA Contact: ychung
Mozilla-inbound Regression Window:

Last Working Environmental Variables:
Device: Flame 3.0
BuildID: 20150220145140
Gaia: e4f7c67378e33e83f88d38ddb4a6c2cabf1423c3
Gecko: e8cfd49ac790
Version: 38.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0

First Broken Environmental Variables:
Device: Flame 3.0
BuildID: 20150220151245
Gaia: e4f7c67378e33e83f88d38ddb4a6c2cabf1423c3
Gecko: e9a8fe34405c
Version: 38.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0

Last Working Gaia First Broken Gecko: Issue DOES reproduce 
Gaia: e4f7c67378e33e83f88d38ddb4a6c2cabf1423c3
Gecko: e9a8fe34405c

First Broken Gaia Last Working Gecko: Issue does NOT reproduce
Gaia: e4f7c67378e33e83f88d38ddb4a6c2cabf1423c3
Gecko: e8cfd49ac790

http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=e8cfd49ac790&tochange=e9a8fe34405c

Caused by bug 1119335
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: regressionwindow-wanted → regression
QA Contact: ychung
Jan-Ivar, can you take a look at this please? This might have been caused by the landing for bug 1119335.
Blocks: 1119335
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker) → needinfo?(jib)

Updated

3 years ago
Flags: needinfo?(hochang)
Please see if Bug 1162412 fixes it. Thanks for finding this.
Flags: needinfo?(jib)
The camera choice regression should be landing soon in Bug 1162412.

(In reply to Fred Lin [:gasolin] from comment #4)
> And once I confirm the camera sharing, the flame is crashed.
> 
> webcamtoy.com 's source is minified, so it might be more efficient to see
> what's passed to gecko and what option cause the crash.

Eric, can you please confirm that you're seeing a crash as well? (sorry I didn't see the comment about the crash right away).

http://webcamtoy.com is likely crashing because it uses enumerateDevices (Bug 1162720).
Depends on: 1162720
Flags: needinfo?(echang)
(Reporter)

Comment 9

3 years ago
Created attachment 8603906 [details]
verify_pass.png

This issue has been verified as pass on latest build of Flame 3.0 and Nexus 5 3.0 by STRs in comment 0.
See attachment:verify_pass.png
Rate:0/5

Device: Flame 3.0 (pass)
Build ID               20150510010201
Gaia Revision          5b2a150f6f5d29bddfaac13fcbbf099376f2f275
Gaia Date              2015-05-09 12:34:41
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/77d92f6d7679
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150510.045933
Firmware Date          Sun May 10 04:59:44 EDT 2015
Bootloader             L1TC000118D0

Device: Nexus 5 3.0 (pass)
Build ID               20150510010201
Gaia Revision          5b2a150f6f5d29bddfaac13fcbbf099376f2f275
Gaia Date              2015-05-09 12:34:41
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/77d92f6d7679
Gecko Version          40.0a1
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150510.044405
Firmware Date          Sun May 10 04:44:24 EDT 2015
Bootloader             HHZ12f
(Reporter)

Updated

3 years ago
status-b2g-master: affected → verified
(Reporter)

Comment 10

3 years ago
Created attachment 8603908 [details]
crash_screenshot.png

Hi Jan-Ivar,
I can see the crash with the STRs:
1. Flash or reset the phone to bring up the FTE and finish the FTE to view the homescreen .
2. Tap Camera from the home screen and wait for the Camera permission view to pop up. 
3. Back home and open the Browser app. 
4. Navigate to webcamtoy.com. 
5. Tap on "Ready? Smile!" and then tap on "Use my camera!".
6. Tap "Share" at "Website Permission" view.
** Wait about 3 sec, device will restart and crash.

I have uploaded the logcat, could you please help with it? Thanks :)

Crash ID: bp-14ef501b-5c17-4a64-bdf8-3f13a2150511
See attachment:crash_screenshot.png and logcat_0547.txt
Rate:3/3

Device: Flame 3.0 (affected)
Build ID               20150510010201
Gaia Revision          5b2a150f6f5d29bddfaac13fcbbf099376f2f275
Gaia Date              2015-05-09 12:34:41
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/77d92f6d7679
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150510.045933
Firmware Date          Sun May 10 04:59:44 EDT 2015
Bootloader             L1TC000118D0
Flags: needinfo?(jib)
(Reporter)

Comment 11

3 years ago
Created attachment 8603909 [details]
logcat_0547.txt
(Reporter)

Updated

3 years ago
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][MGSEI-Triage+]
status-b2g-master: verified → affected
(Reporter)

Updated

3 years ago
status-b2g-master: affected → verified
(In reply to Sue from comment #10)
> Crash ID: bp-14ef501b-5c17-4a64-bdf8-3f13a2150511

Thanks, yes this is Bug 1162720. There's a patch for it there, but I need someone to land it.
Flags: needinfo?(jib)
Yes, my flame crashes with today's build.

Build ID               20150513160203
Gaia Revision          338f66e6a96491d2f5854b188c6b141ceb690d97
Gaia Date              2015-05-13 14:08:45
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/1fab94ad196c
Gecko Version          41.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150513.193307
Firmware Date          Wed May 13 19:33:19 EDT 2015
Bootloader             L1TC000118D0
 
(In reply to Jan-Ivar Bruaroey [:jib] from comment #8) 
> Eric, can you please confirm that you're seeing a crash as well? (sorry I
> didn't see the comment about the crash right away).
> 
> http://webcamtoy.com is likely crashing because it uses enumerateDevices
> (Bug 1162720).
Flags: needinfo?(echang)
Bug 1162720 landed today. Please verify once the patch is included in the build.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Keywords: verifyme
Resolution: --- → DUPLICATE
Duplicate of bug: 1162720
Was this ever verified? Bug 1162720 never landed on 39 (my bad) and needs to be uplifted to beta asap.
Flags: needinfo?(anygregor)
(In reply to Jan-Ivar Bruaroey [:jib] from comment #15)
> Was this ever verified? Bug 1162720 never landed on 39 (my bad) and needs to
> be uplifted to beta asap.

B2G 2.2 is based on gecko 37. So we don't have to uplift anything for b2g.
Qawanted to verify on master.
Flags: needinfo?(anygregor)
Keywords: qawanted
Created attachment 8624011 [details]
Flame3.0_video.3gp

Hi Gregor,
This crash problem cannot be reproduced on latest build of Nexus5 3.0 by the STR in comment 10. But on Flame 3.0, after step 6, wait for several seconds, device will exit Browser app and go back to Homescreen automatically. Could you please help with it? Thanks!
Please see attachment: Flame3.0_video.3gp & Flame3.0_logcat_2245.txt
Occurrence time: 22:45
Nexus5 3.0 reproduce rate: 0/10
Flame 3.0 reproduce rate: 10/10

Device information:
Nexus5 3.0 (no repro)
Build ID               20150617160207
Gaia Revision          b404c41c5471c31610e64defb74ec066b411e724
Gaia Date              2015-06-17 17:01:15
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/a3f280b6f8d5
Gecko Version          41.0a1
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150617.192258
Firmware Date          Wed Jun 17 19:23:17 EDT 2015
Bootloader             HHZ12f

Flame 3.0
Build ID               20150617160207
Gaia Revision          b404c41c5471c31610e64defb74ec066b411e724
Gaia Date              2015-06-17 17:01:15
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/a3f280b6f8d5
Gecko Version          41.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150617.192003
Firmware Date          Wed Jun 17 19:20:14 EDT 2015
Bootloader             L1TC000118D0
Flags: needinfo?(anygregor)
Created attachment 8624012 [details]
Flame3.0_logcat_2245.txt
Keywords: qawanted
This issue is verified fixed in the latest Flame and Aries 2.5 builds.
Using the STR provided in the original bug description, as well as the STR in Comment 10, Camera share prompt properly appears, allowing the user to select the Back or Front camera, both the device and browser app remain performant. I did not encounter any device crashes, gaia resets, or app terminations.

Removing verifyme keyword.

Environmental Variables:
Device: Aries 2.5
BuildID: 20150902124951
Gaia: e2fab8f6ac345ecde10a1350e699be9ceb6987d6
Gecko: 1b687fcb5213153855c7ac0f8392ce0a4a7e3382
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 43.0a1 (2.5) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0

Environmental Variables:
Device: Flame 2.5
BuildID: 20150902030203
Gaia: b75979ec8862bd5799a7c42e938d3f67be38d6ae
Gecko: fb720c90eb49590ba55bf52a8a4826ffff9f528b
Gonk: c4779d6da0f85894b1f78f0351b43f2949e8decd
Version: 43.0a1 (2.5) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0
Flags: needinfo?(jmercado)
Keywords: verifyme
Flags: needinfo?(jmercado)
Flags: needinfo?(anygregor)
You need to log in before you can comment on or make changes to this bug.