Closed Bug 1162020 Opened 7 years ago Closed 6 years ago

layout/style/tests has a leak when running as --run-by-dir on win7/8

Categories

(Core :: Layout, defect)

defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox40 --- affected

People

(Reporter: jmaher, Unassigned)

References

Details

as seen on try server:
https://treeherder.mozilla.org/#/jobs?repo=try&revision=72b7fdf2885a&filter-searchStr=mochitest-5%20win%20debug


02:21:28     INFO -  TEST-INFO | leakcheck | default process: leak threshold set at 0 bytes
02:21:28     INFO -  TEST-INFO | leakcheck | plugin process: leak threshold set at 0 bytes
02:21:28     INFO -  TEST-INFO | leakcheck | tab process: leak threshold set at 25000 bytes
02:21:28     INFO -  TEST-INFO | leakcheck | geckomediaplugin process: leak threshold set at 20000 bytes
02:21:28     INFO -  == BloatView: ALL (cumulative) LEAK AND BLOAT STATISTICS, default process 3876
02:21:28     INFO -       |<----------------Class--------------->|<-----Bytes------>|<----Objects---->|
02:21:28     INFO -       |                                      | Per-Inst   Leaked|   Total      Rem|
02:21:28     INFO -     0 |TOTAL                                 |       20     1512|101456900       12|
02:21:28     INFO -   226 |EventTokenBucket                      |      232      464|       2        2|
02:21:28     INFO -   380 |Mutex                                 |       32       64|   10935        2|
02:21:28     INFO -   489 |ReentrantMonitor                      |       40       80|    6526        2|
02:21:28     INFO -   874 |nsDeque                               |       96       96|   28502        1|
02:21:28     INFO -  1218 |nsSocketTransportService              |      272      272|       1        1|
02:21:28     INFO -  1275 |nsTArray_base                         |        8        8|28390753        1|
02:21:28     INFO -  1285 |nsThread                              |      240      240|      58        1|
02:21:28     INFO -  1290 |nsTimerImpl                           |      144      288|   17763        2|
02:21:28     INFO -  nsTraceRefcnt::DumpStatistics: 1399 entries
02:21:28     INFO -  TEST-INFO | leakcheck | default process: leaked 2 EventTokenBucket (464 bytes)
02:21:28     INFO -  TEST-INFO | leakcheck | default process: leaked 2 Mutex (64 bytes)
02:21:28     INFO -  TEST-INFO | leakcheck | default process: leaked 2 ReentrantMonitor (80 bytes)
02:21:28     INFO -  TEST-INFO | leakcheck | default process: leaked 1 nsDeque (96 bytes)
02:21:28     INFO -  TEST-INFO | leakcheck | default process: leaked 1 nsSocketTransportService (272 bytes)
02:21:28     INFO -  TEST-INFO | leakcheck | default process: leaked 1 nsTArray_base (8 bytes)
02:21:28     INFO -  TEST-INFO | leakcheck | default process: leaked 1 nsThread (240 bytes)
02:21:28     INFO -  TEST-INFO | leakcheck | default process: leaked 2 nsTimerImpl (288 bytes)
02:21:28  WARNING -  TEST-UNEXPECTED-FAIL | leakcheck | default process: 1512 bytes leaked (EventTokenBucket, Mutex, ReentrantMonitor, nsDeque, nsSocketTransportService, ...)

I need to bisect this down a bit to try and find the root cause.
narrowed it down to:
[test_viewport_units.html]
[test_visited_image_loading.html]
[test_visited_image_loading_empty.html]
[test_visited_lying.html]
[test_visited_pref.html]
[test_visited_reftests.html]
[test_bug525952.html]

waiting on try results, this should be known later today of the root cause.
and the winner is....

test_visited_reftests.html (https://dxr.mozilla.org/mozilla-central/source/layout/style/test/test_visited_reftests.html)

I am glad that this is a single file, now to figure out.

:dbaron, I see that you have edited this file a lot in the history of it.  Can you look at this or help me find someone to look at it?
Flags: needinfo?(dbaron)
oh, this is 2 months outdated- we might go ahead and disable this test until there is more time to look into it.
closing as worksforme then, thanks for double checking here.
Status: NEW → RESOLVED
Closed: 6 years ago
Flags: needinfo?(dbaron)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.