xpidl string/wstring attribute setters should be constipated

VERIFIED DUPLICATE of bug 7610

Status

()

P3
major
VERIFIED DUPLICATE of bug 7610
20 years ago
2 years ago

People

(Reporter: brendan, Assigned: mike+mozilla)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

20 years ago
See netwerk/base/public/nsIURI.idl and the nsIURI.h generated from it by xpidl:
SetSpec takes a char *, it should take a const char *.  This causes tons of code
to cast away const, which is evil and wrong.  Just as xpidl constipates string
in param C++ bindings, so it should for the setter's in param.

I'm willing to help fix all the breakage that changing xpidl to constipate
string setters will induce.

It'd help to have the generated NS_DECL* macros for interface methods, so we
could romp through the tree and replace those method decls with the macro call,
rather than add const here and there.

/be
(Assignee)

Updated

20 years ago
Status: NEW → RESOLVED
Last Resolved: 20 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 1

20 years ago
Marking as a dup of 7610.

I was putting this off before because of the xpidl-doesn't-build-on-mac problem
with changing xpidl synchronously with all of the .idl, but I just proved to
myself last night that (with beard's building fixes) it works just fine.  So
there shouldn't be any obstacle beyond finding a nice stretch of green to land
in.  Perhaps after XPCOM_DECL_IFOO, which I hope to do next.

Thanks for the offer of assistance; I might need it.


*** This bug has been marked as a duplicate of 7610 ***

Updated

20 years ago
Status: RESOLVED → VERIFIED

Comment 2

20 years ago
verified dup

Updated

11 years ago
Component: xpidl → XPCOM
QA Contact: mike+mozilla → xpcom
You need to log in before you can comment on or make changes to this bug.