bgcolor of <TR> affect space setted by cellspacing parametr (standard mode)

RESOLVED FIXED in Future

Status

()

defect
P4
normal
RESOLVED FIXED
18 years ago
18 years ago

People

(Reporter: aha, Assigned: karnaze)

Tracking

Trunk
Future
x86
Windows NT
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [awd:tbl][bug?])

Actual:
If you set bgcolor for <TR> (in standard mode), color is setted for whole row
including space between table cells.

Expected:
Space between table cells has color of parent - TABLE etc.

Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:0.9.6+) Gecko/20011219
In standard mode, this is the expected behavior. It does bother me a little that 
we do it differently than other browsers and there isn't a lot of support pro or 
con in the CSS spec.
I don't remember what the latest decision of the CSS WG was -- I think this may
have been discussed at some point recently.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Temporarily moving to future until a milestone can be assigned. 
Status: NEW → ASSIGNED
Target Milestone: --- → Future
BTW MSIE6 it renders same in standard-compliant mode as Mozilla in compatible
mode. So this bug is also MSIE parity.
Target Milestone: Future → mozilla1.0
i don't think this is a real bug. according to karnazes note this is expected 
behaviour.

is it a bug or not?
Whiteboard: [awd:tbl][bug?]
I don't think it's the expected behavior, but either we need to discuss it in
the CSS working group or remember the result of the last discussion.
Depends on: 4510
Moving to 1.1, but it should be fixed when 4510 lands.
Target Milestone: mozilla1.0 → mozilla1.1

*** This bug has been marked as a duplicate of 4510 ***
Status: ASSIGNED → RESOLVED
Closed: 18 years ago
Resolution: --- → DUPLICATE
didn't mean to dup.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Status: REOPENED → ASSIGNED
Priority: -- → P4
Target Milestone: mozilla1.1 → Future
Fixed by checkin for 4510
Status: ASSIGNED → RESOLVED
Closed: 18 years ago18 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.