Closed Bug 1162193 Opened 4 years ago Closed 4 years ago

Pocket initial panel load displays incorrectly

Categories

(Firefox :: Pocket, defect, P1)

38 Branch
defect
Points:
1

Tracking

()

RESOLVED FIXED
Iteration:
41.1 - May 25
Tracking Status
firefox40 --- affected

People

(Reporter: sphilp, Assigned: jaws)

References

Details

(Whiteboard: [fixed by bug 1161793])

Attachments

(1 file)

It seems that any initial action of the panel following an account/state change (clean launch, logging out of pocket to view the sign up panel) seems to require a second opening of the panel to view the proper panel/content layout.

A few example steps

1. Start a fresh instance of nightly (as in you are not logged in to a pocket account, and this is the first run of nightly)
2. Click the toolbar button, the panel is very tiny and you can't see any of the login content
3.Close and reopen the panel, now everything looks fine

Or

1. Log in to a pocket account
2. Open the panel via the toolbar button, you should see the 'saved to pocket' view as expected
3. Log out of pocket account
4. Open the panel via the toolbar button, you will see small view of the login/signup panel
5. Close and reopen the panel and everything is fine

This was initially filed on https://github.com/Pocket/Firefox/issues/39
Noticed this behavior across platforms: Windows 7 (x64), Ubuntu 14.04 (x64), Mac OS X 10.9.5.
Flags: qe-verify+
OS: Unspecified → All
Hardware: Unspecified → All
Duplicate of this bug: 1162077
[Tracking Requested - why for this release]: Broken first-time-usage UI on a new feature.
Screenshot of the issue. Happens once on any new window.
Should be fixed by bug 1161793.
Depends on: 1161793
Blocks: Pocket
Priority: -- → P1
I've verified that the patch from bug 1161793 which is landed on fx-team fixes this problem.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1161793
Flags: qe-verify+
Let's use "Depends on" rather than dupe here given the summary differences.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Duplicate of this bug: 1162951
Assignee: nobody → jaws
Status: REOPENED → ASSIGNED
Whiteboard: [fixed by bug 1161793]
Jared, is this bug fixed or should it still be open?
Flags: needinfo?(jaws)
This bug is now fixed.
Status: ASSIGNED → RESOLVED
Iteration: --- → 41.1 - May 25
Points: --- → 1
Closed: 4 years ago4 years ago
Flags: qe-verify-
Flags: needinfo?(jaws)
Flags: firefox-backlog+
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.