Add additional e10s testrun to Travis and AppVeyor

RESOLVED FIXED in mozilla40

Status

Testing
Firefox UI Tests
RESOLVED FIXED
3 years ago
2 years ago

People

(Reporter: whimboo, Assigned: whimboo)

Tracking

(Blocks: 1 bug)

unspecified
mozilla40
Points:
---

Firefox Tracking Flags

(e10s+)

Details

Attachments

(1 attachment)

Given that we can now run our tests also with e10s enabled, travis and appveyor should run those beside non-e10s mode by default.
Looks like we have two failures with e10s enabled:

 1:46.72 TEST_START: MainThread test_about_private_browsing.py TestAboutPrivateBrowsing.testCheckAboutPrivateBrowsing

 2:18.78 TEST_END: MainThread ERROR, expected PASS

Traceback (most recent call last):

  File "/Users/travis/.venv/lib/python2.7/site-packages/marionette_client-0.12-py2.7.egg/marionette/marionette_test.py", line 296, in run

    testMethod()

  File "/Users/travis/build/mozilla/firefox-ui-tests/firefox_ui_tests/functional/private_browsing/test_about_private_browsing.py", line 41, in testCheckAboutPrivateBrowsing

    self.wait_for_condition(lambda mn: len(self.windows.all) == 2)

  File "/Users/travis/.venv/lib/python2.7/site-packages/marionette_client-0.12-py2.7.egg/marionette/marionette_test.py", line 677, in wait_for_condition

    raise TimeoutException("wait_for_condition timed out")

TimeoutException: TimeoutException: wait_for_condition timed out


 2:19.43 TEST_START: MainThread test_back_forward.py TestBackForward.test_back_forward

 2:24.40 TEST_END: MainThread FAIL, expected PASS

Traceback (most recent call last):

  File "/Users/travis/.venv/lib/python2.7/site-packages/marionette_client-0.12-py2.7.egg/marionette/marionette_test.py", line 296, in run

    testMethod()

  File "/Users/travis/build/mozilla/firefox-ui-tests/firefox_ui_tests/functional/toolbar/test_back_forward.py", line 64, in test_back_forward

    self.assertEquals(self.marionette.get_url(), self.test_urls[i])

AssertionError: u'http://127.0.0.1:49598/layout/mozilla_grants.html' != 'http://127.0.0.1:49598/layout/mozilla_mission.html'


I will check if it is an easy fix. If not lets skip them for now with e10s turned on.
Created attachment 8602593 [details] [review]
github_pull_request.txt

Both of the tests were created as examples and aren't in our list of P1 tests, so lets skip them for now.
Attachment #8602593 - Flags: review?(cmanchester)
Attachment #8602593 - Flags: review?(cmanchester) → review+

Updated

3 years ago
Blocks: 984139
tracking-e10s: --- → +
Duplicate of this bug: 1145226
https://github.com/mozilla/firefox-ui-tests/commit/6438d3004f8cdf8c7ad363464ccb4ae7f6696939
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 40
Product: Mozilla QA → Testing
You need to log in before you can comment on or make changes to this bug.