Closed Bug 1162427 Opened 7 years ago Closed 7 years ago

the "reset assignee to default" checkbox / functionality should be visible

Categories

(bugzilla.mozilla.org :: User Interface, defect, P1)

Production
defect

Tracking

()

RESOLVED FIXED

People

(Reporter: glob, Unassigned)

References

Details

Attachments

(1 file)

the "reset assignee to default" checkbox / functionality should be visible even when not changing the component.

markh suggested implementing this by treating an empty string as "reset to default".  along with a placeholder showing the default user i think that would work.
Summary: the "reset assignee to default" checkbox / functionality should be visible even when not changing the component → the "reset assignee to default" checkbox / functionality should be visible
Attached patch 1162427_1.patchSplinter Review
- add a bug_start_of_set_all hook
- use hook to set default assignee and/or qa_contact if value empty
- set default value as a placeholder
Attachment #8603201 - Flags: review?(dkl)
Duplicate of this bug: 1167571
Comment on attachment 8603201 [details] [diff] [review]
1162427_1.patch

Review of attachment 8603201 [details] [diff] [review]:
-----------------------------------------------------------------

Works well in my testing of UI and API. r=dkl
Attachment #8603201 - Flags: review?(dkl) → review+
To ssh://gitolite3@git.mozilla.org/webtools/bmo/bugzilla.git
   4bc64fd..776ee55  master -> master
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Component: User Interface: Modal → User Interface
Assignee: glob → nobody
You need to log in before you can comment on or make changes to this bug.