Closed Bug 1162445 Opened 4 years ago Closed 4 years ago

The Pocket toolbar button's functionality is not properly adapting to private browsing, where the user is no longer signed in

Categories

(Firefox :: Pocket, defect)

40 Branch
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1160407
Tracking Status
firefox40 --- affected

People

(Reporter: avaida, Unassigned)

References

Details

Attachments

(1 file)

Reproducible on:
Nightly 40.0a1 (2015-05-06)

Affected platforms:
Windows 7 (x64), Ubuntu 14.04 (x64), Mac OS X 10.9.5

Preconditions:
* The user is logged into Pocket.

Steps to reproduce:
1. Launch Firefox.
2. Click menu [≡] → New Private Window.
3. Open a website that's currently not saved to Pocket, e.g. http://example.com/
4. Click the Pocket button from the toolbar.
5. From the confirmation panel displayed by the Pocket toolbar button, click "View list".

Expected result:
* The Pocket toolbar button displays the sign-in/sign-up panel.
* The page is NOT saved to Pocket, since the user is logged out of Pocket in a newly opened private window.

Actual result:
* Clicking the Pocket toolbar button displays a confirmation panel stating that the page was successfully saved to Pocket.
* Clicking "View list" redirects the user to Pocket's login page.
* The page that was saved apparently without being logged into Pocket is actually saved to the user's Pocket account.
Flags: qe-verify+
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1160407
You need to log in before you can comment on or make changes to this bug.