Pocket landing page - Development

RESOLVED FIXED

Status

www.mozilla.org
Pages & Content
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: ckprice, Assigned: craigcook)

Tracking

Production

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [kb=1743307] [engagement-fxGrowth-2015])

Attachments

(1 attachment)

This bug is to track the development of the Pocket landing page.

Design/copy in bug 1162745

EtherPad detailing flows
https://spring15.etherpad.mozilla.org/pocket-dev

Targeting the following locales:
en-us
es-es
ru-ru
ja-jp
de-de
(Assignee)

Updated

3 years ago
Whiteboard: [engagement-fxGrowth-2015] → [kb=1743307] [engagement-fxGrowth-2015]
Confirmed with team today that the URL for this page s/b

mozilla.org/firefox/pocket/
(Assignee)

Comment 2

3 years ago
This page is previewable at https://www-demo4.allizom.org/firefox/pocket/ (just stubbed out for the moment; it'll look better soon).

The git working branch is https://github.com/mozilla/bedrock/tree/bug-1162755-pocket-landing-page and the specific template is at firefox/pocket.html

@flod: Since I haven't seen a final design yet I want to ask Lee if there might be any special text formatting (line breaks, bold, italics, etc) before we extract/expose strings. I'll ping him first thing in the morning (our time) and let you know.
(In reply to Craig Cook (:craigcook) from comment #2)
> @flod: Since I haven't seen a final design yet I want to ask Lee if there
> might be any special text formatting (line breaks, bold, italics, etc)
> before we extract/expose strings. I'll ping him first thing in the morning
> (our time) and let you know.

Thanks. I've seen the branch, I'll start extracting strings for both yours and Alex's branch, and wait later today to expose strings.
I have one more string to update on /whatsnew, which I'll do first thing this morning.
(Assignee)

Comment 5

3 years ago
Created attachment 8606340 [details]
Design mockups

Design mockups for reference. Note these mockups show the older download CTA; the button label has been changed to "Download Firefox".
Final approved design posted in bug 1162745 comment 12
Please use this SUMO article for the "LEARN MORE" case (updated Firefox, but Pocket icon is not in the toolbar): https://support.mozilla.org/en-US/kb/where-pocket-button-firefox
:craigcook - do you expect to have this up on demo today?
Flags: needinfo?(craigcook.bugz)
(Assignee)

Comment 9

3 years ago
(In reply to Cory Price [:ckprice] from comment #8)
> :craigcook - do you expect to have this up on demo today?

Yeah, sorry, I'm a bit behind on responsive/mobile stuff and catching up. I also need to add in the JavaScript that I just got from Alex to trigger the tour bit. I should have demo4 updated later today and I'm on target for a pull request by Tuesday.
Flags: needinfo?(craigcook.bugz)
(Assignee)

Comment 10

3 years ago
Merged to master with https://github.com/mozilla/bedrock/commit/339a0317242fb310ac853f291de19870da328b14
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
(Assignee)

Comment 11

3 years ago
This page needs the waffle switch "pocket_active" in order to appear on stage/prod. (cc jgmize)
You need to log in before you can comment on or make changes to this bug.