Counting bookmarks is broken in Library

VERIFIED FIXED in Firefox 40

Status

()

defect
VERIFIED FIXED
4 years ago
2 months ago

People

(Reporter: Virtual, Assigned: mak)

Tracking

({nightly-community, regression})

40 Branch
Firefox 41
Points:
1
Dependency tree / graph
Bug Flags:
firefox-backlog +
qe-verify -

Firefox Tracking Flags

(firefox39 unaffected, firefox40+ verified, firefox41 verified)

Details

Attachments

(1 attachment)

STR:
1. Open "Library" (Ctrl+Shift+B)
2. Go to "Bookmarks Toolbar", "Bookmarks Menu" or "Unsorted Bookmarks"
3. Select more than 1 bookmark


Actual results:
Bookmark items aren't counted.


Expected results:
I can see how much items I selected.



Regression window (mozilla-inbound-win32)
Good:
https://ftp.mozilla.org/pub/mozilla.org/firefox/tinderbox-builds/mozilla-inbound-win32/1429822861/

Bad:
https://ftp.mozilla.org/pub/mozilla.org/firefox/tinderbox-builds/mozilla-inbound-win32/1429824241/

Pushlog:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=2f2888ca42c2&tochange=2a1ddf08a4b4


Probably caused by:
Bug 951651 - Make bookmarkProperties, Star UI and Library info pane work with PlacesTransactions. r=mak



[Tracking Requested - why for this release]: Regression
Flags: needinfo?(mano)
Flags: needinfo?(mak77)
It still works for folders and separators, for uris we just show the tags field, while we should also show the count.
Assignee: nobody → mak77
Status: NEW → ASSIGNED
Points: --- → 1
Flags: qe-verify-
Flags: needinfo?(mano)
Flags: needinfo?(mak77)
Flags: firefox-backlog+
Summary: Counting items is broken in bookmark Library → Counting bookmarks is broken in Library
Iteration: --- → 40.3 - 11 May
Posted patch patch v1Splinter Review
we are now always hiding/showing this programmatically, no need to hide it by default.
Attachment #8604104 - Flags: review?(ttaubert)
Attachment #8604104 - Flags: review?(ttaubert) → review+
https://hg.mozilla.org/mozilla-central/rev/fc6a63c30b02
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 41
Requesting an uplift to Firefox 40
Flags: needinfo?(mak77)
Comment on attachment 8604104 [details] [diff] [review]
patch v1

Approval Request Comment
[Feature/regressing bug #]: bookmarks panel rewrite
[User impact if declined]: selecting multiple items in the Library doesn't show the selection count
[Describe test coverage new/current, TreeHerder]: Nightly, manual testing
[Risks and why]: low risk oneline xul fix
[String/UUID change made/needed]: none
Flags: needinfo?(mak77)
Attachment #8604104 - Flags: approval-mozilla-aurora?
Comment on attachment 8604104 [details] [diff] [review]
patch v1

Pretty trivial change. Aurora+
Attachment #8604104 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
You need to log in before you can comment on or make changes to this bug.