Closed Bug 1163184 Opened 4 years ago Closed 4 years ago

Window titlebar has strange borders in devedition theme on windows

Categories

(Firefox :: Theme, defect, P2)

All
Windows 8
defect

Tracking

()

VERIFIED FIXED
Firefox 43
Tracking Status
firefox42 --- verified
firefox43 --- verified

People

(Reporter: ntim, Assigned: Gijs)

References

Details

(Whiteboard: [polish-backlog][difficulty=easy])

Attachments

(1 file, 1 obsolete file)

Screenshot : http://cl.ly/image/3F2c0U44442h/o
(sidebar thing is unrelated, it's an addon)
Component: Developer Tools: Inspector → Theme
The borders are caused by some lw-theme code :
- The side border are set on #navigator-toolbox 
- The top border is set on #browser-panel
Thanks for the report Tim.  Any chance could put together a patch that fixes this?
Flags: needinfo?(ntim.bugs)
Whiteboard: [devedition-40][difficulty=easy]
Attached patch Patch (obsolete) — Splinter Review
Assignee: nobody → ntim.bugs
Status: NEW → ASSIGNED
Flags: needinfo?(ntim.bugs)
Attachment #8603626 - Flags: review?(gijskruitbosch+bugs)
Comment on attachment 8603626 [details] [diff] [review]
Patch

Review of attachment 8603626 [details] [diff] [review]:
-----------------------------------------------------------------

I don't understand why these need to be !important. 

I also don't think removing the top border is a good idea. Without the border-top, there is no top border on the window frame, which will look broken. What's more, just removing border-top will only work on aero and win8/10. There's sprinklings of other CSS around that use some background image manipulation tricks to have something resembling a native top border.

If the top border looks wrong on win10/win8, we should fix the top border generally, not just remove it in the devedition case.
Attachment #8603626 - Flags: review?(gijskruitbosch+bugs) → review-
Priority: -- → P2
Assignee: ntim.bugs → nobody
Status: ASSIGNED → NEW
See Also: → 1166722
Whiteboard: [devedition-40][difficulty=easy] → [polish-backlog][difficulty=easy]
Duplicate of this bug: 1192593
Split this off from the patch in bug 1188194.
Assignee: nobody → gijskruitbosch+bugs
Status: NEW → ASSIGNED
No longer depends on: 1188194
https://hg.mozilla.org/mozilla-central/rev/fc1f32837c78
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 43
Attached patch Patch v2Splinter Review
Approval Request Comment
[Feature/regressing bug #]: devedition theme look&feel on windows
[User impact if declined]: borders on devedition that it doesn't need
[Describe test coverage new/current, TreeHerder]: nope, styling only
[Risks and why]: low/none, devedition-theme-CSS-only change
[String/UUID change made/needed]: nope
Attachment #8603626 - Attachment is obsolete: true
Attachment #8654160 - Flags: review+
Attachment #8654160 - Flags: approval-mozilla-aurora?
Comment on attachment 8654160 [details] [diff] [review]
Patch v2

Polish, taking it.
Attachment #8654160 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
I have reproduced this bug on Firefox Version 42.0a1

It's fixed and verified on Latest Firefox Beta & DevEdition
Build ID 	20151005144425
User Agent 	Mozilla/5.0 (Windows NT 6.3; rv:42.0) Gecko/20100101 Firefox/42.0

Latest DevEdition
Build ID 	20151008004031
User Agent 	Mozilla/5.0 (Windows NT 6.3; rv:43.0) Gecko/20100101 Firefox/43.0

Tested OS- Windows8.1 32bit
QA Whiteboard: [bugday-20151008]
Status: RESOLVED → VERIFIED
Depends on: 1224713
You need to log in before you can comment on or make changes to this bug.