Update /mailnews/ for PLDHashTable API changes

RESOLVED FIXED in Thunderbird 41.0

Status

defect
--
blocker
RESOLVED FIXED
4 years ago
3 years ago

People

(Reporter: philip.chee, Assigned: njn)

Tracking

Thunderbird 41.0
Dependency tree / graph

Thunderbird Tracking Flags

(thunderbird40 unaffected, thunderbird41 fixed, seamonkey2.35 unaffected, seamonkey2.36 unaffected, seamonkey2.37 fixed)

Details

Attachments

(1 attachment, 1 obsolete attachment)

Reporter

Description

4 years ago
Bug 1161377 - PLDHashTable: Add and use an initializing constructor and destructor
https://hg.mozilla.org/mozilla-central/rev/2eae1608bcfa
Reporter

Comment 1

4 years ago
Bug 1161377 removed PL_NewDHashTable() and PL_DHashTableDestroy()
Replace with multi-arg constructor
Attachment #8603754 - Flags: review?(rkent)
Assignee

Comment 2

4 years ago
Sorry about this. I was going to write a patch on Friday for c-c but a fresh checkout didn't compile and then I got distracted and then Friday was over and it was the weekend.
Comment on attachment 8603754 [details] [diff] [review]
Patch v1.0 Proposed fix [Checked in: Comment 4]

I did not try to compile this with the other ongoing breakage, but the changes are pretty straightforward. r=me
Attachment #8603754 - Flags: review?(rkent) → review+

Updated

4 years ago
Keywords: checkin-needed
OS: Unspecified → All
Hardware: Unspecified → All

Comment 4

4 years ago
Comment on attachment 8603754 [details] [diff] [review]
Patch v1.0 Proposed fix [Checked in: Comment 4]

https://hg.mozilla.org/comm-central/rev/95616afdd719
Attachment #8603754 - Attachment description: Patch v1.0 Proposed fix → Patch v1.0 Proposed fix [Checked in: Comment 4]

Updated

4 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 40.0
Assignee

Comment 5

4 years ago
Bug 1161377's patches were backed out, so this will have to backed out at some point too. Sorry :(
Backed out https://hg.mozilla.org/comm-central/rev/fcbd8eb059be due to backout of m-c bug.

Reopening since we'll probably want to reland later.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Updated

4 years ago
Duplicate of this bug: 1165665
Assignee

Comment 8

4 years ago
The new PLDHashTable API changes are in bug 1170416.
Depends on: 1170416
No longer depends on: 1161377
Summary: Remove PL_NewDHashTable() and PL_DHashTableDestroy() from /mailnews/ → Update /mailnews/ for PLDHashTable API changes
Assignee

Updated

4 years ago
Assignee: philip.chee → n.nethercote
Status: REOPENED → ASSIGNED
Assignee

Updated

4 years ago
Attachment #8603754 - Attachment is obsolete: true

Updated

4 years ago
Duplicate of this bug: 1171080
Comment on attachment 8614513 [details] [diff] [review]
Update /mailnews/ for PLDHashTable API changes

https://hg.mozilla.org/comm-central/rev/b3a333547c76

I pushed this since we are busted without it.
Attachment #8614513 - Flags: review?(rkent) → review+

Updated

4 years ago
Severity: normal → blocker
Target Milestone: Thunderbird 40.0 → Thunderbird 41.0
Version: Trunk → 41

Updated

4 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago4 years ago
Resolution: --- → FIXED

Updated

3 years ago
Duplicate of this bug: 1129692
You need to log in before you can comment on or make changes to this bug.