Closed Bug 1163453 Opened 6 years ago Closed 6 years ago
The naming of Interval::Union is confusing in particular when the two intervals are disjoints. It should be renamed. MediaByteRange which provides a similar API, use Extents.
Rename Interval::Union into Interval::Span. I've considered all the other options, in particual Extents but an extent has a very precise definition which doesn't appear to cover what we want to do here. BTW, the MediaByteRange::Extents implementation is buggy (it's not commutative) but that's for another bug
Attachment #8604469 - Flags: review?(matt.woodrow)
Assignee: nobody → jyavenard
Status: NEW → ASSIGNED
Attachment #8604469 - Flags: review?(matt.woodrow) → review+
You need to log in before you can comment on or make changes to this bug.