bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Some GitHub pages open as totally black; somehow related to the "It's All Text" extension

RESOLVED WORKSFORME

Status

()

Firefox
Extension Compatibility
RESOLVED WORKSFORME
3 years ago
3 years ago

People

(Reporter: njn, Unassigned)

Tracking

({addon-compat})

Trunk
x86_64
All
addon-compat
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(e10s+, firefox40 affected)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Bug 1128238's patch is causing the content window to go totally black for me when I open a new tab, in some cases. 

Steps to reproduce.

- Create a new profile.

- Install the "It's All Text" extension from https://addons.mozilla.org/en-US/firefox/addon/its-all-text/.

- Open https://github.com/torvalds/linux in a tab.

- Middle-click on the "linux" link in the "torvalds / linux" text in the top-left corner.

- Wait for the new tab to finish loading, i.e. the spinning icon has to stop in the tab strip.

- Click on the new tab. The entire content is black.

- Move the mouse cursor around the page. As the cursor rolls over things that change, such as links, they will get drawn. If I scroll, the parts of the content that get newly drawn show up ok. If I switch to another tab and switch back, the entire content is drawn ok.

So it seems like we're failing to draw any of the page content for some reason, but the pieces get redrawn on demand as necessary.
(Reporter)

Comment 1

3 years ago
Created attachment 8603943 [details]
screenshot

Here's a screenshot that shows what it looks like once a few page elements have been drawn.
(Reporter)

Updated

3 years ago
Summary: Some GitHub pages open as totally back; somehow related to the "It's All Text" extension → Some GitHub pages open as totally black; somehow related to the "It's All Text" extension
(Reporter)

Updated

3 years ago
OS: Windows 10 → Linux

Comment 2

3 years ago
reproduced on windows7
Keywords: pp
OS: Linux → All

Updated

3 years ago
tracking-e10s: --- → ?
(Reporter)

Comment 3

3 years ago
Thank you for reproducing, Alice.

Comment 4

3 years ago
WORKAROUND:
check "Disable" radio button of the "Edit button position" in "It's All Text" option.

Updated

3 years ago
Blocks: 905436
tracking-e10s: ? → +
(Reporter)

Comment 5

3 years ago
(In reply to Alice0775 White from comment #4)
> WORKAROUND:
> check "Disable" radio button of the "Edit button position" in "It's All
> Text" option.

Unfortunately that effectively disables the add-on :(

Jim, any ideas?
Flags: needinfo?(jmathies)

Comment 6

3 years ago
Does anyone know why this is in plugins and blocks bug 1128238?
Component: Plug-ins → Extension Compatibility
Flags: needinfo?(jmathies)
Keywords: pp → addon-compat
Product: Core → Firefox
Can't reproduce this on Mac OS. I contacted the developer through AMO anyway.
(Reporter)

Comment 8

3 years ago
(In reply to Jim Mathies [:jimm] from comment #6)
> Does anyone know why this is in plugins and blocks bug 1128238?

It blocks bug 1128238 because I bisected the problem down to bug 1128238. It's in plugins becauses I cloned that bug to make this bug.

Comment 9

3 years ago
I have *zero* clue why "It's All Text!" would cause this to happen.  I don't have much access to Windows anymore; I just have my gaming-not-development machine running Windows 8.1.  IAT seems to work fine on my OS X laptops.

Comment 10

3 years ago
I can't replicate this on Windows 10 x64, can anyone replicate it?
(Reporter)

Comment 11

3 years ago
I can no longer reproduce this, yay!
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.