Closed Bug 1163577 Opened 4 years ago Closed 4 years ago

Reader View button shouldn't be shown on Pocket website

Categories

(Firefox :: Pocket, defect, P3)

38 Branch
defect

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: adalucinet, Unassigned)

References

Details

Reproducible on Firefox 38.0.5 beta 1 (Build ID: 20150510205200)
Affected platforms: Mac OS X 10.9.5, Ubuntu 14.04 x64 and Windows 8.1 x86

Pre-requisites: User is logged in to Pocket.

Steps to reproduce:
1. Navigate to a Reader View compatible page, e.g. http://bits.blogs.nytimes.com/2015/03/30/the-path-toward-tomorrows-internet/ 
2. Click on Enter Reader View button.
3. Save the article into Pocket. 
4. Go to Pocket List. 
5. Click on the saved article from step 3.
6. Click on Go back button.

Expected result:
The Enter Reader View button is not displayed in URL bar.

Actual result:
The Enter Reader View button is displayed in URL bar.

Notes:
1. Screencast: https://goo.gl/PBbOlH
2. Browser console output: 'Error requesting favicon URL for about:reader content: favicon not found for uri' thrown by ReaderParent.jsm:111:0 when clicking on Reader View icon in Pocket list.
It looks like Pocket is opening the page in Reader Mode. Is it possible for content to visit an about:reader URL? Something funny is going on here, do one of you want to look in to this?
Flags: needinfo?(margaret.leibovic)
Flags: needinfo?(gijskruitbosch+bugs)
From the screencast, it seems like things are working as expected. It sounds like this is just an `isProbablyReaderable` issue (we're detecting the pocket list page as readerable, even though ideally we wouldn't show the reader view button). Hitting the button doesn't fail, so this doesn't seem like a big deal, but we could add some hard-coded logic for getpocket.com as part of our partnership.

As for the error in the browser console, that just looks like a separate issue that we couldn't get a favicon to show for reader view: http://mxr.mozilla.org/mozilla-central/source/browser/modules/ReaderParent.jsm#102
Flags: needinfo?(margaret.leibovic)
Yeah, I talked with Gijs over IRC about this and he thinks they are hiding the content but we aren't properly detecting that the paragraphs are being hidden.
Flags: needinfo?(gijskruitbosch+bugs)
(In reply to :Margaret Leibovic from comment #2)
> Hitting the button doesn't fail, so this doesn't seem
> like a big deal, but we could add some hard-coded logic for getpocket.com as
> part of our partnership.

Yeah, and we're previously talked about doing exactly this as a simple way to suppress Reader View on sites like Twitter and Reddit (I think those were the examples), where it works fine, but just isn't actually needed. In a perfect world our detection algorithm would be perfect, but this is useful until then. :)

I think this would be especially useful on getpocket.com, because it's a weird mix of two features that we're explicitly drawing attention to. Having a new user start start using Pocket, and also then try out the new Reader View there is likely to be a bit confusing. Feels not-critical, but really nice to have.

OTOH, I can't actually reproduce this right now. Did Pocket happen to work around this?
Summary: Enter Reader View button available in Pocket List page → Reader View button shouldn't be shown on Pocket website
(In reply to Justin Dolske [:Dolske] from comment #4)
> OTOH, I can't actually reproduce this right now. Did Pocket happen to work
> around this?

I'm still seeing this behavior with Firefox 38.0.5 Beta 2 build 1 on Mac OS X 10.8.5.
Blocks: Pocket
Priority: -- → P3
I can't reproduce this now on beta or nightly. Alexandra can you confirm?
Flags: needinfo?(alexandra.lucinet)
Indeed, this seems fixed on my side too - unable to reproduce using 39.0b1 build 2 (Build ID: 20150523155636) and latest 41.0a1 (2015-05-26), under Windows 7 64-bit, Mac OS X 10.9.5 and Ubuntu 14.04 32-bit.
Flags: needinfo?(alexandra.lucinet)
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.