View Source briefly shows window background when flipping remoteness

REOPENED
Unassigned

Status

()

Toolkit
View Source
P3
normal
REOPENED
3 years ago
2 years ago

People

(Reporter: mconley, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(e10s+, firefox41 affected)

Details

When bug 1025146 lands, we'll be switching remoteness for the View Source browser to show the source of remote content. That involves removing the <xul:browser> from the DOM, setting "remote" on it, and re-adding it to the DOM in order for the binding to attach properly and for a proper frame message manager to get set up.

During that window of time when the browser is removed from the DOM, we just show the window background. This will cause an ugly flicker - particularly (I imagine - untested) on Windows Vista / 7, with the Glass backgrounds on the windows.

We should probably just set the background colour on an element behind the browser or something like that.

This is very much polish.
tracking-e10s: ? → +
Hi,

I couldn't reproduce this on Windows 10, Windows 7, Ubuntu 14.04 and Mac OS X 10.7 on the latest Aurora (46.0a2) and when clicking the option to view the source of a page a new tab is opened with a white background and the source code.

Build ID    20160208004010
User Agent  Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:46.0) Gecko/20100101 Firefox/46.0
User Agent  Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:46.0) Gecko/20100101 Firefox/46.0
User Agent  Mozilla/5.0 (X11; Linux x86_64; rv:46.0) Gecko/20100101 Firefox/46.0
User Agent  Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:46.0) Gecko/20100101 Firefox/46.0

Considering this I will mark this issue as Resolved-WFM.

Thanks,
Cipri
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
Note that since this bug was filed, View Source was changed to open in a tab by default instead of a new window[1].

So to reproduce this bug, one must set view_source.tab to false first.

[1]: Which makes this bug even more of a polish bug.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Priority: -- → P3
You need to log in before you can comment on or make changes to this bug.