[Email] LTR subject line has end punctuation placed to left of string when language is set to RTL

VERIFIED FIXED in 2.2 S12 (15may)

Status

defect
P2
normal
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: bzumwalt, Assigned: jrburke)

Tracking

unspecified
2.2 S12 (15may)
ARM
Gonk (Firefox OS)
Bug Flags:
in-moztrap +

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [3.0-Daily-Testing])

Attachments

(4 attachments)

(Reporter)

Description

4 years ago
Posted image Screenshot
Description:
When language is set to Arabic or another RTL language, opening an email with an LTR subject line that has end-sentence punctuation (i.e. "This is a message!") the punctuation shows to the left of the sentence (i.e. "!This is a message")

This only occurs when user opens the email. When viewing email in inbox list view the subject appears as expected.

Repro Steps:
1) Update a Flame to 20150511010202
2) Set language to Arabic
3) Launch email
4) Tap email message that has subject in LTR with end-sentence punctuation


Actual:
In Arabic, email subject heading in LTR language has end sentence punctuation placed to left of string.

Expected:
End sentence punctuation for LTR strings is placed to right of string.

Environmental Variables:
Device: Flame 3.0
Build ID: 20150511010202
Gaia: 6089234ace8b294a8feef064387604bae16254e3
Gecko: d8420a541d1c
Gonk: 040bb1e9ac8a5b6dd756fdd696aa37a8868b5c67
Version: 40.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0

Repro frequency: 3/3, 100%
See attached: screenshot
(Reporter)

Comment 1

4 years ago
Issue DOES reproduce on Flame 2.2

In Arabic, email subject heading in LTR language has end sentence punctuation placed to left of string.

Again, subject appears correctly in inbox list view, issue only appears after tapping on email.

Device: Flame 2.2
Build ID: 20150511002500
Gaia: 528ef60e7cda09ad43478065f5d33bda398fbeb7
Gecko: 8d04cc085cf5
Gonk: ab265fb203390c70b8f2a054f38cf4b2f2dad70a
Version: 37.0 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Delphine, can you take a look at this please?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker) → needinfo?(lebedel.delphine)
Nominating for general triage decision as this happens on a main/often used screen of the email app.
Blocks: email-rtl
blocking-b2g: --- → 2.2?
Flags: needinfo?(lebedel.delphine)
Priority: -- → P2
(Assignee)

Comment 5

4 years ago
Comment on attachment 8606052 [details] [review]
[gaia] jrburke:bug1163741-email-lrt-subject > mozilla-b2g:master

Looks like I just missed adding a dir="auto" for the subject in the message reader. I added that, and some CSS rules to make sure that the text is aligned left or right if in ltr or rtl respectively. I was able to reproduce locally and tested the fix on flame device to confirm the fix.
Attachment #8606052 - Flags: review?(bugmail)
Comment on attachment 8606052 [details] [review]
[gaia] jrburke:bug1163741-email-lrt-subject > mozilla-b2g:master

The non-rectangular red quadrilaterals in the screenshot are surprisingly disconcerting.  I'm crossing my fingers and hoping they're parallelograms.
Attachment #8606052 - Flags: review?(bugmail) → review+
(Reporter)

Comment 7

4 years ago
Ack! I was without my usual image editing program! At the risk of causing further distress, I don't even think the top left corners of the polygons even match up perfectly.
Noooooooooooooo! ;)
(Assignee)

Updated

4 years ago
Keywords: checkin-needed
http://docs.taskcluster.net/tools/task-graph-inspector/#0RYM7lVpR0S8OP-9f7IZYg

The pull request failed to pass integration tests. It could not be landed, please try again.
(Assignee)

Updated

4 years ago
Keywords: checkin-needed
https://github.com/mozilla-b2g/gaia/pull/30073

Autolander could not land the pull request due to not having collaborator rights. This is possibly due to a tree closure. Please check the tree status and request checkin again once the tree is open.
(Assignee)

Updated

4 years ago
Keywords: checkin-needed
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Assignee)

Comment 12

4 years ago
Comment on attachment 8606052 [details] [review]
[gaia] jrburke:bug1163741-email-lrt-subject > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):
Missed this element in the initial dir="auto" changes.

[User impact] if declined:
Odd looking punctuation in rtl if viewing an email with an ltr subject.

[Testing completed]:
Tested on flame device with ltr text in both rtl and ltr UI modes.

[Risk to taking this patch] (and alternatives if risky):
Super low: just adding dir="auto" and some css styles targeted to that element to align the text according to the language direction.

[String changes made]:
none
Attachment #8606052 - Flags: approval-gaia-v2.2?
Comment on attachment 8606052 [details] [review]
[gaia] jrburke:bug1163741-email-lrt-subject > mozilla-b2g:master

Cleared for landing.
Attachment #8606052 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
blocking-b2g: 2.2? → 2.2+

Comment 14

4 years ago
Posted image verify_pass.png
This issue has been verified as pass on latest nightly build of Flame 3.0 and Nexus 5 3.0 by STRs in comment 0.
Result: End sentence punctuation for LTR strings is placed to right of string.
See attachment: verify_pass.png
Rate:0/3

Device: Flame 3.0 (pass)
Build ID               20150517160201
Gaia Revision          afea16de7a76c3b6d15c35fb4c37bac71c8ddc6a
Gaia Date              2015-05-17 03:33:40
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/35918b0441b4
Gecko Version          41.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150517.212430
Firmware Date          Sun May 17 21:24:42 EDT 2015
Bootloader             L1TC000118D0

Device: Nexus 5 3.0 (pass)
Build ID               20150517160201
Gaia Revision          afea16de7a76c3b6d15c35fb4c37bac71c8ddc6a
Gaia Date              2015-05-17 03:33:40
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/35918b0441b4
Gecko Version          41.0a1
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150517.194053
Firmware Date          Sun May 17 19:41:09 EDT 2015
Bootloader             HHZ12f

Updated

4 years ago
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][MGSEI-Triage+]
v2.2: https://github.com/mozilla-b2g/gaia/commit/335c7a827e4a82086ad2f543d746e30f97046f11
Assignee: nobody → jrburke
Target Milestone: --- → 2.2 S12 (15may)

Comment 16

4 years ago
Posted image v2.2_verify_pass.png
This issue has been verified as pass on latest nightly build of Flame 2.2 and Nexus 5 2.2 by STRs in comment 0.
Result: End sentence punctuation for LTR strings is placed to right of string.
See attachment: v2.2_verify_pass.png
Rate:0/5

Device: Flame 2.2 (pass)
Build ID               20150519162501
Gaia Revision          63e9eeec3032318f8a240f80b6a184fa4b50b6e1
Gaia Date              2015-05-19 17:52:15
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/4e078e1364d3
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150519.200807
Firmware Date          Tue May 19 20:08:18 EDT 2015
Bootloader             L1TC000118D0

Device: Nexus 5 2.2 (pass)
Build ID               20150519162501
Gaia Revision          63e9eeec3032318f8a240f80b6a184fa4b50b6e1
Gaia Date              2015-05-19 17:52:15
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/4e078e1364d3
Gecko Version          37.0
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150519.195445
Firmware Date          Tue May 19 19:55:01 EDT 2015
Bootloader             HHZ12f

Updated

4 years ago
Status: RESOLVED → VERIFIED

Comment 17

4 years ago
Test case has been added in moztrap:
https://moztrap.mozilla.org/manage/case/15310/
Flags: in-moztrap+
You need to log in before you can comment on or make changes to this bug.