Closed Bug 1163817 Opened 5 years ago Closed 2 years ago

[Homescreen][SHB] Icons shift slightly on returning to homescreen from an app

Categories

(Firefox OS Graveyard :: Gaia::System, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(b2g-v2.2 unaffected, b2g-master affected)

RESOLVED WONTFIX
Tracking Status
b2g-v2.2 --- unaffected
b2g-master --- affected

People

(Reporter: onelson, Unassigned, NeedInfo)

References

()

Details

(Keywords: regression, Whiteboard: [3.0-Daily-Testing], [systemsfe][SHB-enabled])

Description:
When a user returns from an app to the homescreen (tapping the home button), they will observe the homescreen icons shift slightly down. This only occurs if the software home button is present, though the shift is not equal the height of the button itself.


Repro Steps:
1) Update a Flame to 20150511010202
2) Open Settings
3) Navigate to Developer Settings
4) Enable Software Home button
5) Return to homescreen
6) Observe icons positions

Actual:
Icons shift downwards slightly

Expected:
Icons do not move


Environmental Variables:
----------------------------------------

Device: Flame 3.0
Build ID: 20150511010202
Gaia: 6089234ace8b294a8feef064387604bae16254e3
Gecko: d8420a541d1c
Gonk: a9f3f8fb8b0844724de32426b7bcc4e6dc4fa2ed
Version: 40.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0
**************************************

Issue DOES NOT REPRO on 2.2 for flame devices
Results: 

Device: Flame 2.2
BuildID: 20150511002500
Gaia: 528ef60e7cda09ad43478065f5d33bda398fbeb7
Gecko: 8d04cc085cf5
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
----------------------------------------


Repro frequency: 5/5
See attached: 
video- will link after upload
logcat
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Keywords: regression
Whiteboard: [3.0-Daily-Testing] → [3.0-Daily-Testing], [systemsfe]
QA Contact: ychung
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(pbylenga)
Whiteboard: [3.0-Daily-Testing], [systemsfe] → [3.0-Daily-Testing], [systemsfe][SHB-enabled]
Mozilla-inbound Regression Window:

Last Working Environmental Variables:
Device: Flame 3.0
BuildID: 20150505234844
Gaia: 3e6fd1e0a478af2c95d09ce95c2c6de2de2fec14
Gecko: 266853fe8965
Version: 40.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0

First Broken Environmental Variables:
Device: Flame 3.0
BuildID: 20150506000340
Gaia: 3e6fd1e0a478af2c95d09ce95c2c6de2de2fec14
Gecko: 819c760b572f
Version: 40.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0

Last Working Gaia First Broken Gecko: Issue DOES reproduce 
Gaia: 3e6fd1e0a478af2c95d09ce95c2c6de2de2fec14
Gecko: 819c760b572f

First Broken Gaia Last Working Gecko: Issue does NOT reproduce
Gaia: 3e6fd1e0a478af2c95d09ce95c2c6de2de2fec14
Gecko: 266853fe8965

http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=266853fe8965&tochange=819c760b572f

possibly caused by bug 1160635 or bug 1153539
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Contact: ychung
Blocks: 1153539
David, can you take a look at this please? We think this might have been caused by landing for either bug 1153539 or 1160635.
Blocks: 1160635
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker) → needinfo?(dbaron)
Almost certainly bug 1153539 rather than bug 1160635.
No longer blocks: 1160635
(In reply to David Baron [:dbaron] ⏰UTC-7 from comment #4)
> This may be related to bug 1180509.

And it also likely be related to bug 1153539 changing things so the surface is no longer rendering at a scale of exactly 1.0, but in one dimension by slightly more than 1.0.
This doesn't seem to happen on more recent nightly builds. Do you agree, oliverthor?

If this is working now, but if it still happens on any branches, can you add regressionwindow-wanted to get an anti-regression window to help figure out what fixed this?
Flags: needinfo?(onelson)
I'm still observing this issue on mozilla-central nightlies on master for flame devices

Results: Icons shift downwards slightly returning from an app to homescreen

Device: Flame 2.5
BuildID: 20150806030207
Gaia: 4ede0c6bf5fb0c2896d5393032b395999a154619
Gecko: 07befc6f54e7
Gonk: 41d3e221039d1c4486fc13ff26793a7a39226423
Version: 42.0a1 (2.5) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0
Repro: 10/10

Software home button is the reason behind this issue occurring, and since that isn't default on this device, wanted to make sure this was being observed by those unable to reproduce.

------------------------

Worth mentioning, on the Aries device that has a software home button by design, this issue DOES NOT OCCUR.

Results: Icons do not move returning from an app to homescreen

Device: Aries 2.5
BuildID: 20150806111958
Gaia: 497fe3f938722b0aa49c93f975fad5d9ed3b0a82
Gecko: 22476236b3e1
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 42.0a1 (2.5) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0
Flags: needinfo?(onelson) → needinfo?(jwatt)
(In reply to Oliver Nelson [:oliverthor] from comment #7)
> Software home button is the reason behind this issue occurring, and since
> that isn't default on this device, wanted to make sure this was being
> observed by those unable to reproduce.

Yes, I enabled the software home button and can repro on older builds. Just not with Nightly builds, either pvt or a build I created myself.

> Worth mentioning, on the Aries device that has a software home button by
> design, this issue DOES NOT OCCUR.

Likewise, I haven't seen this issue with any builds with my Z3C which has the software home button by design.
Flags: needinfo?(jwatt)
Oliver, although you can still see it, has it become less pronounced in more recent builds?
Flags: needinfo?(onelson)
Adding qawanted tag as I won't be able to attend to this issue.
Flags: needinfo?(onelson)
Keywords: qawanted
This issue is still reproducible and not less pronounced in latest Flame. With SHB, homescreen appears to shift slightly upon returning to Homescreen. Note that I tested this on Flame with 512MB memory and not 319, because 319 simply kills the homescreen when I'm in an app and every time I return to Home it has to take time to reload the homescreen therefore masking the bug.

Device: Flame 2.5
BuildID: 20150821030209
Gaia: c6705f739fb605031eb2a0b943ba55c64bee5a03
Gecko: 095988abdc560bf8ba07a94a425c6922a3e9bfd6
Gonk: c4779d6da0f85894b1f78f0351b43f2949e8decd
Version: 43.0a1 (2.5) 
Firmware Version: v18Dv4
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(jmercado)
Keywords: qawanted
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmercado)
Mass update: Resolve wontfix all issues with legacy homescreens.

As of 2.6 we have a new homescreen and having these issues open is confusing. All issues will block bug 1231115 so we can use that to re-visit any of these if needed.
Blocks: 1231115
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WONTFIX
I just tested this on yesterday's Aries and am still seeing this issue. We should re-open this bug.
Flags: needinfo?(jmercado)
Sure, everything in the homescreen component was closed prior to migrating to the new homescreen. This is probably in the wrong component.
Status: RESOLVED → REOPENED
Component: Gaia::Homescreen → Gaia::System
Resolution: WONTFIX → ---
Flags: needinfo?(jmercado)
Firefox OS is not being worked on
Status: REOPENED → RESOLVED
Closed: 4 years ago2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.