Downloads don't occur in-place

VERIFIED DUPLICATE of bug 55690

Status

SeaMonkey
General
VERIFIED DUPLICATE of bug 55690
16 years ago
13 years ago

People

(Reporter: bugzilla, Assigned: asa)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
Mozilla downloads files to /tmp, then moves them to their final destination.

Problems:
1.  It's very hard to monitor the progress of such a download.
2.  If /tmp has only 100MB available, it's *TOTALLY IMPOSSIBLE* to download a
101MB file - even if the final destination has gigabytes free.
3.  There seems to be no way to override this behavior, even to specify an
alternative.  Certainly, it appears that Mozilla is ignoring TMPDIR and similar
environment variables.

I would be happiest if the download simply occurred in-place.  I could live with
it being optional, or with, at the *VERY* least, the option of specifying an
alternative location for temporary downloads.

Comment 1

16 years ago
I hesitate between bug 55690 and bug 69938

Comment 2

16 years ago
Gilles, you 're hesitating because this report actually describes two bugs. But,
because the reporter gives more importance to disk space problem, I would mark
it as a dupe of bug 55690.

*** This bug has been marked as a duplicate of 55690 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 4

16 years ago
reporter: you didn't include a build id, or milestone identifier.
according to my source readings, and a friend's testing of mozilla0.9.7linux, 
we do honor TMPDIR. vrfy dupe.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.