[gtk3] crash @ nsNativeThemeGTK::DrawWidgetBackground()

RESOLVED DUPLICATE of bug 1127752

Status

()

RESOLVED DUPLICATE of bug 1127752
3 years ago
3 years ago

People

(Reporter: stransky, Unassigned)

Tracking

Trunk
x86_64
Linux
Points:
---

Firefox Tracking Flags

(firefox41 affected)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Reproduction steps:

go to duckduckgo.com, enter some text to search box

in nsNativeThemeGTK::DrawWidgetBackground()
900	  cairo_t *cairo_ctx =
901	    (cairo_t*)aDrawTarget.GetNativeSurface(NativeSurfaceType::CAIRO_CONTEXT); 

cairo_ctx is null.
(Reporter)

Comment 1

3 years ago
looks like the aDrawTarget is mozilla::gfx::DrawTargetDual type which does not have cairo context.
(Reporter)

Comment 2

3 years ago
Created attachment 8605210 [details] [diff] [review]
workaround

I'm not sure this is the correct solution but it prevents the browser from crashes at least.
(Reporter)

Comment 3

3 years ago
Comment on attachment 8605210 [details] [diff] [review]
workaround

Karl, what do you think? Do we need to support the dual target?
Attachment #8605210 - Flags: feedback?(karlt)
Comment on attachment 8605210 [details] [diff] [review]
workaround

Do the changes from bug 1127752 help here?

If not, its probably best to ask Lee what the best solution here would be.
(He will be more likely to know about DrawTargetDual than I.)
Attachment #8605210 - Flags: feedback?(karlt)
(Reporter)

Comment 5

3 years ago
Bug 1127752 seems to fixed that, Thanks.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1127752
You need to log in before you can comment on or make changes to this bug.