Closed Bug 1164096 Opened 6 years ago Closed 6 years ago

[Secure Element][v2.2] REQUEST_SIM_CLOSE_CHANNEL: Parcel handling threw TypeError: this.sendDefaultResponse is not a function

Categories

(Firefox OS Graveyard :: RIL, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(b2g-v2.2 affected, b2g-master unaffected)

RESOLVED DUPLICATE of bug 1113054
Tracking Status
b2g-v2.2 --- affected
b2g-master --- unaffected

People

(Reporter: tauzen, Unassigned)

References

Details

When I'm closing channel to the SecureElement I can see the following error in the RIL log:
I/Gecko   (  195): RIL Worker: [0] Handling parcel as REQUEST_SIM_CLOSE_CHANNEL
I/Gecko   (  195): RIL Worker: Parcel handling threw TypeError: this.sendDefaultResponse is not a function
I/Gecko   (  195): REQUEST_SIM_CLOSE_CHANNEL@resource://gre/modules/ril_worker.js:6689:3

This is actually blocking the possibility to resolve the channel.close() Promise in web apps. 

I'm not sure how it's possible that sendDefaultResponse is not present in ril_worker in 2.2. I can see that it was added in Bug 1124550, which has status-b2g-v2.2 fixed.
(In reply to Krzysztof Mioduszewski[:tauzen] from comment #0)
> When I'm closing channel to the SecureElement I can see the following error
> in the RIL log:
> I/Gecko   (  195): RIL Worker: [0] Handling parcel as
> REQUEST_SIM_CLOSE_CHANNEL
> I/Gecko   (  195): RIL Worker: Parcel handling threw TypeError:
> this.sendDefaultResponse is not a function
> I/Gecko   (  195):
> REQUEST_SIM_CLOSE_CHANNEL@resource://gre/modules/ril_worker.js:6689:3
> 
> This is actually blocking the possibility to resolve the channel.close()
> Promise in web apps. 
> 
> I'm not sure how it's possible that sendDefaultResponse is not present in
> ril_worker in 2.2. I can see that it was added in Bug 1124550, which has
> status-b2g-v2.2 fixed.

The status flag in bug 1124550 isn't correct, it doesn't be included in 2.2 actually. I will correct it.

And the follow-up patch in bug 1113054 did be merged into b2g37_v2_2 trunk, I am going to request to merge the follow-up patch there and will mark this bug as duplicated once the patch is merged.
The follow-up patch for v2.2 in bug 1113054 is merged.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1113054
You need to log in before you can comment on or make changes to this bug.