Closed Bug 1164453 Opened 7 years ago Closed 7 years ago

crash in mozilla::MediaCodecDataDecoder::InitDecoder(mozilla::jni::Ref<mozilla::widget::sdk::Surface> const&)

Categories

(Firefox for Android Graveyard :: Audio/Video, defect)

40 Branch
ARM
Android
defect
Not set
critical

Tracking

(firefox41 fixed)

RESOLVED FIXED
Firefox 41
Tracking Status
firefox41 --- fixed

People

(Reporter: aaronmt, Assigned: esawin)

References

Details

(Keywords: crash)

Crash Data

Attachments

(1 file, 1 obsolete file)

This bug was filed from the Socorro interface and is 
report bp-b7847bd6-ae67-42f5-b98b-3936f2150512.
=============================================================
Looks like mCallback is null, which isn't supposed to happen. Eugen, can you look into how/why this could happen? Maybe adding an assertion that aCallback is non-null would be good too.
Assignee: nobody → esawin
Flags: needinfo?(esawin)
The callback can be set to null in some cases (e.g. [1]), we should always check before calling functions on it.

[1] https://dxr.mozilla.org/mozilla-central/source/dom/media/fmp4/MP4Reader.cpp#99
Flags: needinfo?(esawin)
There are cases where mCallback can be unset (initialization) and others where it must be set (decoding), we should check/assert accordingly.
Attachment #8606359 - Flags: review?(snorp)
Attachment #8606359 - Flags: review?(snorp) → review+
My assumption that we only initialize the decoder without a callback was wrong. We also do it in places ([1]) which eventually call into the decoder loop.
That means, we can never assume that the callback is set.

Also, sorry for introducing a new macro, but sporadic variadic function support in templates may currently cause us issues on some platforms/compiler versions.

[1] https://dxr.mozilla.org/mozilla-central/source/dom/media/fmp4/MP4Decoder.cpp#276
Attachment #8606359 - Attachment is obsolete: true
Attachment #8606487 - Flags: review?(snorp)
Attachment #8606487 - Flags: review?(snorp) → review+
Status: NEW → ASSIGNED
https://hg.mozilla.org/mozilla-central/rev/3b142e9bc1f5
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 41
Duplicate of this bug: 1167476
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.