Closed Bug 1164508 Opened 5 years ago Closed 4 years ago

[e10s] Selecting "Kill Content" in response to a plugin hang breaks future plugin loads

Categories

(Firefox :: General, defect)

defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1119442
Tracking Status
e10s m8+ ---
firefox41 --- affected

People

(Reporter: jimm, Assigned: jimm)

Details

Attachments

(1 file)

Attached patch debug patchSplinter Review
STR:

1) trigger a plugin hang (you can use the attached patch)
2) wait for the browser notification
3) instead of killing the plugin, kill the content process
4) attempt to restore your session from the crashed tab page

result: pages with plugins endlessly load without displaying content, eventually content times out again and the hang notification is displayed.

rinse wash repeat
Is this a bug? The plugin is still hung, so the behavior makes sense to me.
(In reply to Bill McCloskey (:billm) from comment #1)
> Is this a bug? The plugin is still hung, so the behavior makes sense to me.

Maybe the bug is that we offer killing the content process as a fix for a plugin hang then? I assumed that if I chose content it meant the browser would take both content and plugin processes down.
Assignee: nobody → jmathies
tracking-e10s: --- → m8+
Depends on: 1119442
doing this work in bug 1119442.
Status: NEW → RESOLVED
Closed: 4 years ago
No longer depends on: 1119442
Resolution: --- → DUPLICATE
Duplicate of bug: 1119442
You need to log in before you can comment on or make changes to this bug.