Right-clicking on Yahoo! HTML videos is treated as a left-click (opens ad page in new tab or pauses video) in Firefox, but not Chrome

RESOLVED WONTFIX

Status

Tech Evangelism
Desktop
RESOLVED WONTFIX
3 years ago
2 years ago

People

(Reporter: cpeterson, Unassigned)

Tracking

unspecified

Firefox Tracking Flags

(platform-rel ?, firefox38 affected, firefox38.0.5 affected, firefox39 affected, firefox40 affected, firefox41 affected, firefox42 affected, firefox49 affected)

Details

(Reporter)

Description

3 years ago
STR:
1. Disable Flash ("Never Activate" setting)
2. Load https://screen.yahoo.com/other-space/episode-1-great-beyond-beyond-070100400.html
3. When the video starts playing, right-click on it to ensure that it is HTML5 video and not Flash.

RESULT:
Right-clicking pauses the video as if you left-clicked. However, right-clicking a second time does not resume video playback. This happens in Firefox but not Chrome.

This only seems to happen for Yahoo!'s HTML5 videos. I can't reproduce on YouTube.

I'm using Firefox 38 on OS X 10.10.3.
(Reporter)

Comment 1

3 years ago
Kev, do you have a contact on the Yahoo! Screen video team? Their HTML5 video controls are misbehaving in Firefox but not Chrome.
Flags: needinfo?(kev)

Comment 2

3 years ago
Filed with Yahoo!; will update as I get a expected time to fix or a wontfix.
Flags: needinfo?(kev)
(Reporter)

Updated

3 years ago
status-firefox42: --- → affected
Summary: Right-clicking on Yahoo! HTML videos is treated as a left-click ("pause") in Firefox, but not Chrome → Right-clicking on Yahoo! HTML videos is treated as a left-click (opens ad page in new tab or pauses video) in Firefox, but not Chrome
Kev, would it be helpful if we try to find the bug for them? (Unless you know if they already have a fix in the pipeline).
Flags: needinfo?(kev)

Comment 4

2 years ago
Believe this was addressed some time ago. Closing it out. WFM.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(kev)
Resolution: --- → WORKSFORME
(Reporter)

Comment 5

2 years ago
I can still reproduce this in Nightly 49 when right-clicking on the HTML5 video with my laptop's trackpad or a real mouse. To receive HTML5 video instead of Flash from Yahoo, you must set Flash as "Never Activate" in the Add-ons Manager. Right-clicking on the HTML5 video works correctly in Chrome 50.
Status: RESOLVED → REOPENED
status-firefox49: --- → affected
Resolution: WORKSFORME → ---
Hallvord, can you dig in here?
Flags: needinfo?(hsteen)
(Reporter)

Comment 7

2 years ago
On further investigation, I don't think we need to do anything here. This is a problem in the Yahoo video player and not a bug in Firefox. The video player has similar pause-on-left-click problems in Chrome when Flash is enabled (the reverse of the Firefox STR). I don't think further debugging of this problem is a good use of our time.
Status: REOPENED → RESOLVED
Last Resolved: 2 years ago2 years ago
Flags: needinfo?(hsteen)
Resolution: --- → WONTFIX

Comment 8

2 years ago
Will flag with Yahoo team though. Wasn't sure if it was any HTML5 video; if it's Yahoo's player, we can ask them to look into it. Thanks, Chris.
Sounds good, thanks Chris and Kev.
platform-rel: --- → ?
You need to log in before you can comment on or make changes to this bug.