String search needs grouping capabilities with AND and OR functionality

RESOLVED DUPLICATE of bug 1193778

Status

P3
enhancement
RESOLVED DUPLICATE of bug 1193778
3 years ago
9 months ago

People

(Reporter: camd, Unassigned)

Tracking

Details

(Reporter)

Description

3 years ago
This way you could say something like "(B and WINNT 5.) OR (Windows 7)" 

I'm not sure what the "right" syntax is.  But this would be really convenient for downstream consumers to share URLs to the specific data they care about.

Comment 1

3 years ago
Is there an API to determine which keywords are valid ones?

I think we will need in mozci a way to match a buildernames to specific filters on TH.
(Reporter)

Comment 2

3 years ago
No api to retrieve that at the moment.  But that could be added.  Or at least added to the docs.
(Reporter)

Comment 3

3 years ago
For this, we may consider this syntax for that search: 
https://support.google.com/websearch/answer/2466433?hl=en
Severity: normal → enhancement
Priority: -- → P3
Component: Treeherder → Treeherder: Frontend
Status: NEW → RESOLVED
Last Resolved: 9 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1193778
You need to log in before you can comment on or make changes to this bug.